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Abstract: 

Axonal transport is a process essential for neuronal function and survival that takes place on 

the cellular highways – the microtubules. It requires three major components: the 

microtubules that serve as tracks for the transport, the motor proteins that drive the 

movement, and the transported cargoes with their adaptor proteins. Axonal transport could be 

controlled by tubulin posttranslational modifications, which by decorating specific 

microtubule tracks could determine the specificity of cargo delivery inside neurons. However, 

it appears that the effects of tubulin modifications on transport can be rather subtle, and might 

thus be easily overlooked depending on which parameter of the transport process is analysed. 

Here we propose an analysis paradigm that allows detecting rather subtle alterations in 

neuronal transport, as induced for instance by accumulation of posttranslational 

polyglutamylation. Analysing mitochondria movements in axons, we found that neither the 

average speed nor distance travelled were affected by hyperglutamylation, but we detected an 

about 50% reduction of the overall motility, suggesting that polyglutamylation controls the 

efficiency of mitochondria transport in axons. Our protocol can readily be expanded to the 

analysis of the impact of other tubulin modifications on the transport of a range of different 

neuronal cargoes. 
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1. Introduction 

Intracellular transport is an essential process for all eukaryotic cells, as it allows to deliver 

organelles, mRNA and proteins to their predestined locations in different cellular 

compartments [1]. The complex morphology of neurons (very long and ramified axons and 

many dendrites) is particularly challenging for the intracellular transport machinery, which 

has to work efficiently and adapt to varying physiological requirements throughout the entire 

life span of an organism. In particular axonal transport, which can cover long distances, needs 

to be stringently controlled [2]. Defects in axonal transport have been linked to many 

neurodegenerative disorders, and are suspected to be one of the early molecular defects in 

many of them [3-5]. One of the key mechanisms to control microtubule properties, and their 

interactions with molecular transport machineries are posttranslational modifications (PTMs) 

of tubulins – the building blocks of microtubules [6]. 

Neuronal microtubules are highly enriched with a variety of tubulin PTMs such as 

acetylation, detyrosination, and polyglutamylation [7]. Polyglutamylation is a particularly 

complex PTM, as it can generate branch-chains of variable numbers of glutamate residues 

selectively on a- or b-tubulin. Thus, polyglutamylation can potentially encode a large variety 

of information into one and the same microtubule [6]. The signals generated by 

polyglutamylation are determined by the specificity of the modifying [8,9] and demodifying 

enzymes [10,11], which in turn can be regulated by cell-type specific expression, subcellular 

localisation, as well as by adapting the cellular response to external cues [12]. While little is 

so far known on how polyglutamylation is regulated by signalling pathways, it has been 

shown that the major polyglutamylases in neurons are TTLL1 and TTLL7 [13,8], and the key 

deglutamylases are CCP1 and CCP6 [10,14]. 

Deregulation of tubulin PTMs in cells can result in microtubule dysfunctions and eventually 

in disease conditions [15]. Indeed, analyses of several mouse models have demonstrated that 

aberrations in the levels of tubulin polyglutamylation are linked to cilia-related disorders, 

such as respiratory problems [16], defects in spermatogenesis [17-19] and sperm motility 

[20], retinal degeneration [21], or neurodegeneration [14,10,22,23]. 

Mutation or loss of CCP1, one of the major neuronal deglutamylases, leads to unopposed, and 

thus accumulating polyglutamylation, which results in degeneration of several neuronal 

populations in the brain, the most emblematic being Purkinje cells [18,10,14]. Strikingly in 

these mice, some parts of the brain do not degenerate, nor show signs of increased 
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polyglutamylation. We showed that this was due to the compensation by a second 

deglutamylase, Ccp6, which was selectively expressed in cerebral cortex and hippocampus, 

thus protecting these brain regions [14]. These findings were the first to indicate that cell-

specific expression of enzymes involved in polyglutamylation can result in cell-specific 

functions, or defects.  

Despite first insights in a widespread implication of tubulin polyglutamylation in pathological 

conditions [15], underlying molecular mechanisms remained largely elusive, primarily 

because of a number of technical limitations. These limitations are exemplified when studying 

sensitive biological processes such as axonal transport. Although there are reports linking 

transport changes to polyglutamylation [24-26], the direct role of polyglutamylation in 

controlling transport in neurons has only been recently addressed on primary neurons of the 

now-available knockout mouse models. One study measured axonal transport in cerebellar 

granule cells from ccp1-/- mice, as the cerebellum is the most affected brain region in this 

mouse model [22]. In order to determine the impact of increased polyglutamylation in 

hippocampal neurons, we developed a specific approach to convert Ccp1flox/floxCcp6flox/flox 

neurons into ccp1-/-ccp6-/- in the culture dish (cite flox protocol paper here). Measuring axonal 

transport of mitochondria, we found clear aberrations, however, only one parameter - the 

overall motility of these organelles – was affected. This could have easily been overlooked 

when analysing only the motile mitochondria, which is why we used a paradigm that included 

all mitochondria, even the non-motile ones [14]. 

Here we describe our procedure for imaging axonal transport in neurons with altered tubulin 

PTMs, as well as our analysis paradigm to apprehend a range of different, potentially subtle 

changes in axonal transport. As an example, we show the impact of increased 

polyglutamylation on the mitochondrial transport. This method can be readily extended to 

study the transport of other cellular cargoes, and different tubulin PTMs. 

Development of the analysis paradigm 

One way to study axonal transport is to follow selected, single particles throughout the 

imaging period, and determine their complex movement behaviour (e.g. overall displacement, 

frequency of changes in direction, mean anterograde and retrograde speed, etc.). However, 

some cargoes, such as mitochondria or endosomes, are very dense in axons, making it 

difficult to reliably track the entire path of every moving particle throughout the imaging 

period. Analysing only the ‘trackable’ particles, however, can introduce an unwanted bias in 

the study.  
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To avoid this, we based our analyses paradigm on previously published work [27,28], 

analysing individual “runs”, rather than tracing the movement of single particles throughout 

the imaging period. A “run” is defined as an uninterrupted, unidirectional motility event at 

constant speed. Thus, a change in the speed of a moving particle marks the beginning of a 

new run (Fig. 1). While this analysis paradigm does not inform us on the complex movement 

of single particles (changes between anterograde and retrograde movements, final destination 

of a particle), it provides unbiased, statistically exploitable data for parameters that might be 

altered by tubulin PTMs for both, anterograde and retrograde transport: the speed at which a 

transport cargo moves along differentially modified microtubules, or its persistence (how long 

a particle moves before stopping). By taking into account the total number of particles in the 

field of observation, we can further determine the overall motility within the particle 

population, thus also taking into account all the non-motile particles in the imaged axon.  

Using this analysis paradigm, we investigated the impact of abnormally increased 

polyglutamylation on axonal transport in hippocampal neurons at DIV4 (4 days in vitro) (cite 

our other method paper here). In neurons with hyperglutamylated microtubules, both, average 

speed and time of single runs were unaltered in both, anterograde and retrograde direction, 

while the overall motility of mitochondria was reduced to about 50% of the control [14] (see 

Fig. 4). This effect could not have been discovered with an approach focusing on tracing only 

motile mitochondria. We therefore believe that our paradigm for axonal-transport analysis can 

be used in a broader range of applications, especially when studying subtle changes such as 

those induced by tubulin PTMs [14]. 
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2. Materials 

2.1 Imaging of Axonal Transport 

1. CO2 Testing Equipment (Thermo ScientificTM #50121515) 

2. Thermometer 

3. Primary mouse hippocampal neurons with normal and modified microtubules cultured 

on 35-mm glass bottom dishes (Ibidi #81158).  

4. B27 medium: For 100 ml, add 2 ml of 50´ B27 solution (Thermo Fisher #17504044), 

1 ml of 100´ Glutamax (Thermo Fisher #35050038) and 1 ml of 100´ Penicillin-

Streptomycin (Life Technologies #15140130) to 96 ml of plain Neurobasal medium 

(Thermo Fisher #21103049).  

5. Conditioned medium: B27 medium incubated with neurons from DIV0, which is not 

only equilibrated with the cell culture incubator’s atmosphere but importantly with 

any signalling/growth molecules released by the neurons in to the medium. See (other 

method paper to cite) for preparing conditioned medium. 

6. Nikon Ti-E spinning disk inverted confocal laser microscope equipped with a 60´ oil 

immersion objective (N.A. 1.40) and an ORCA-Flash 4.0 camera (Hamamatsu) 

controlled through MetaMorph software. 

7. 1 mM MitoTrackerTM Red CMXRos (Thermo Fisher #M7512): Dissolve 50 µg of 

MitoTrackerTM in 94 µl of Dimethyl Sulfoxide (DMSO) (Sigma #D8418). Aliquot by 

10 µl and store at -20°C. Avoid repeated cycles of freeze-thaw. 

2.2 Analysis of Axonal Transport 

1. ImageJ 1.47v equipped with ‘nd Stack Builder’ and ‘KymoToolBox’ plugins. 

2. Microsoft Excel and GraphPad Prism or equivalent software to plot and statistically 

test the obtained data. 
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3. Methods 

In the current protocol, we describe general criteria to follow during the imaging of axonal 

transport and the analysis paradigm we developed to characterize the transport in neurons in 

which tubulin PTMs are modulated (Figs. 1, 2). Using this method, we have analysed the 

mitochondria transport in neurons with normal and abnormally increased polyglutamylation 

[14]. To obtain primary neurons with increased polyglutamylation, we developed a cell-

culture based system, in which primary neurons are isolated from Ccp1flox/floxCcp6flox/flox mice, 

and subsequently transduced with either a GFP-encoding (control), or a GFP-2A-cre-

recombinase encoding lentivirus (to induce the knockout of the two deglutamylases and 

induce hyperglutamylation) (cite other method article).  

We analysed mitochondria transport using the commercially available dye, MitoTrackerTM. 

On DIV4, mitochondrial movements were recorded in the GFP-expressing neurons for 1 min, 

and subsequently converted to kymographs and analysed using the ‘KymoToolBox’ plugin 

[29] for ImageJ [30]. When re-drawing the particle movements in the kymographs, we 

separately assigned each uninterrupted movement (defined by a constant speed = slope in the 

kymograph) as one “run” (Figs. 1, 3). Displacement events of less than 0.10 µm/s were 

considered as immotile.  

For each single experiment (Figs. 1, 4a-e), we analysed the distribution of run speed and run 

time for both, anterograde and retrograde transport. Based on the total amount of particles in 

the field of observation, we then determined the overall motility of the particle population. Of 

all the parameters measured, only the overall motility of the mitochondria was strongly 

decreased in neurons with hyperglutamylation, as compared to control cells (Fig. 4) [14].  

To exclude that the expression of cre recombinase in the neurons affects the transport, we 

performed an equivalent set of experiments in wild-type neurons. We demonstrated that the 

expression of GFP-2A-cre did not affect any of the previously measured parameters of 

mitochondrial transport, thus demonstrating that the decrease of motility in 

Ccp1flox/floxCcp6flox/flox neurons transduced with GFP-2A-cre was indeed a result of the 

knockout of the two deglutamylases, and thus of the microtubule hyperglutamylation it 

induced [14]. 

 

3.1 Imaging of Axonal Transport 
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1. Before starting the experiment use a thermometer and CO2-testing device to manually 

verify the temperature and CO2 levels of the microscope imaging chamber. If needed, 

calibrate the device such that the imaging stage is at 37°C and 5% CO2. see Note 1.  

2. On the day of imaging, remove the medium from the glass-bottom dishes and gently 

wash the transduced neurons with conditioned medium to remove any remains of the 

lentivirus from the dish. Pipette the medium gently, always against the edge of the 

dish and never directly on the neurons. See Note 2.  

3. Thaw an aliquot of 1 mM MitoTrackerTM solution (main stock). Prepare an 

intermediate 2 µM stock solution by adding 1 µl of the main stock to 500 µl of PBS. 

4. Dilute the intermediate stock solution to a final concentration of 2 nM MitoTrackerTM 

by adding 1 µl of 2 µM intermediate stock solution to 1 ml of conditioned medium. 

5. Remove the neurobasal culture medium from the dish and quickly, yet gently add 1 ml 

of conditioned medium containing 2 nM of MitoTrackerTM. Leave the dish in the 

incubator for 1 min. See Note 3.  

6. Remove the medium containing MitoTrackerTM and gently wash the neurons with 

500 µl of conditioned medium to get rid of any unbound MitoTrackerTM dye. Finally, 

add 1 ml of conditioned medium to the neurons and bring them to the microscope 

chamber for live imaging. 

7. Image neurons immediately using a Nikon Ti-E spinning disk inverted confocal laser 

microscope equipped with a 60´ oil immersion objective (N.A 1.40) and an ORCA-

Flash4.0 camera (Hamamatsu), set at 2´2 binning operated by Leica MM AF imaging 

software. See Note 4.  

8. After the imaging stage is set, focus on the neurons using bright-field light. DO NOT 

USE the laser to prevent photobleaching and damaging the neurons. 

9. Once the neurons are in focus, use bright-field to find a suitable neuron and identify 

the axon by its typical characteristics – the longest neurite extending from the cell 

body. Dendrites at DIV4 are much shorter and thicker compared to axons (Fig. 2). See 

Note 5.  

10. If it is not possible to capture the cell body and axon in the image, write down the 

position of the cell body, and its distance from the actual imaging area. 
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11. Switch to laser fluorescence and verify that the chosen neuron is GFP-positive. 

Change the excitation wavelength (in the case of MitotrackerTM Red CMXRos) and 

bring the transport particles in focus. See Note 6.  

12.  Set the gain or intensity of laser to a minimal value at which the transport particles are 

still clearly visible. Keep the laser settings constant for imaging all neurons in a single 

experiment. See Note 7.  

13. Record the particle movements in the axon in streaming mode every 300 ms for a total 

of 1 min. see Note 8.  

14. Acquire differential interference contrast (DIC) and GFP-fluorescence image of the 

axon used for imaging transport to assess the general appearance of the neuron, which 

can eventually give some indications on the health of the neuron. 

15. For the settings we use, acquisition of each neuron will generate one DIC image of the 

neuron, one image of the GFP expression in the cell, 201 time-lapse images 

corresponding to 201 time frames of the movie, and one ‘.nd’ file. 

16. For each dish, image a minimum of five neurons, however we prefer to image around 

ten neurons if possible. This is important as the dynamics of axonal transport are 

inherently heterogenous among individual neurons in culture, and can furthermore be 

affected by small variations in the experimental conditions.  

17. Image each dish for no more than 30 min, as constant laser exposure is deleterious to 

the neurons. 

3.2 Analysis of Axonal Transport 

We recommend creating a separate folder for each analysed neuron and saving there all the 

files generated during the different steps of analysis. In this example, we assume that the 

name of the cell and the folder is ‘Name’. 

1. Open the ‘Name.nd’ MetaMorph file in the ImageJ software by drag-dropping the file 

on the ImageJ icon or toolbar to visualize the tiff images of the corresponding movie 

(Fig. 3a). In the ‘Bio-formats Import Options’ window, select view stack with 

‘hyperstack’ and uncheck all other options. See Note 9.  

2. Calibrate the hyperstack by using ‘Image > Properties’ menu in ImageJ. Unit of length 

for defining pixel size is µm and for the frame interval time is seconds. If ImageJ 
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automatically calibrates the hyperstack, confirm that the values are correct. See 

Note 10.  

3. Save the file as ‘Name_stack.tiff’ in its dedicated folder (Fig. 3a). Once the stack file 

is generated and saved, the individual files corresponding to all the timepoints of the 

movie (Name-t0.tiff – Name-t201.tiff) and the corresponding ‘Name.nd’ file can be 

deleted. 

4. Create a maximum intensity projection of the tiff stack file by using ‘Image > Stacks > 

Z Project’. Subsequently, select ‘projection type’ as maximum, and start slice and stop 

slice as 1 and 201, respectively (Fig. 3b). 

5. Select the ‘segmented line’ or ‘freehand’ line tool and manually identify the axon, in 

which the cargo movement will be quantified (Fig. 3c). If needed, adjust the intensity 

of the maximum projection image beforehand (by using ‘Image > Adjust > 

Brightness/Contrast’) to better visualize the axon. As a general rule, always trace the 

axon from the cell body towards the axonal terminal (proximal – distal). See Note 11.  

6. Add the traced path of the axon to ‘ROI manager’ by pressing ‘t’. Save the ROI as 

‘Name_axon.roi’ by using ‘More >> save’ option.  

7. Close the maximum intensity projection image and apply the ROI to the 

‘Name_stack.tiff’ file. 

8. Use the ‘KymoToolBox’ by selecting ‘Plugins > KymoToolBox > Draw Kymo’ menu 

to generate the kymograph and the kymostack of the movement in the selected axon. 

Define the ‘Width’ as 15 pixels (for the width of identified axon in step 5) and select 

‘Get kymo’ and ‘Get kymoStack’ (Fig. 3d). The kymograph represents particle 

movement in time vs. space, while the kymostack generates a straightened movie of 

the identified axon, which can be later helpful in the identification of particle’s 

movement. Refer to ‘https://github.com/fabricecordelieres/IJ_KymoToolBox’ for 

detailed description of the plugin. See Note 12.  

9. Save the generated kymograph and kymostack as ‘Kymograph from Name_stack.tif’ 

and ‘Kymostack from Name_stack.tif’, respectively in the dedicated folder. 

10. On the kymograph, trace all possible individual runs (Fig. 3e) of the particle 

trajectories. If necessary use the kymostacks to help identifying the trajectories. Add 

each tracing to the ‘ROI manager’ by pressing ‘t’. To keep track of the traced 
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trajectories, select ‘Show All’ on ‘ROI manager’. Save all the ROIs as 

‘Name_stack_kymo.zip’ file in the dedicated folder. See Note 13.  

11. Select ‘Plugins > KymoToolBox > Analyse Kymo’ to retrieve the parameters of each 

run. Select ‘Outward is’ as ‘From left to right’ and ‘Line width’ as 3 (line width for 

representation of colour-coded runs). Set ‘Lim. speed’ as 0.10 µm/sec – runs with 

speed lower than 0.10 µm/sec are considered immotile. Select ‘Log all data’ and 

‘Show colored kymo’ to generate a table with the values of movement parameters of 

trajectories traced in step 10 and a colour-coded kymograph (Fig. 3f). As this analysis 

paradigm focuses on individual runs, use the data highlighted in yellow, which 

correspond to individual runs with constant speed and direction, and discard the data 

highlighted in grey, which correspond to summary of several runs. For the same 

reason, we only use run length (Cum_Dist), run speed (Mean_Speed) and run duration 

(Ttl_Time) parameters for further analysis (Fig. 3f, red box). Immotile trajectories are 

shown as vertical lines in blue while motile trajectories (runs) were shown as diagonal 

lines (green for anterograde and red for retrograde). 

12. Save the colour-coded kymograph as ‘Tracks from kymograph from Name_stack.tiff’ 

and the results table as ‘Results_Name.xls’ in the dedicated folder. 

13. Use the ‘Kymograph from Name_stack.tif’ to determine the number of particles and 

the length of the axon (in µm) used for analysis (Fig. 3g). See Note 14.  

14. To calculate one of the parameters to be analysed, the particle density (mitochondria, 

vesicles) in the axons, use the following equation: 

𝐷𝑒𝑛𝑠𝑖𝑡𝑦	𝑜𝑓	𝑝𝑎𝑟𝑡𝑖𝑐𝑙𝑒𝑠	[/100	µ𝑚	𝑜𝑓	𝑎𝑥𝑜𝑛] =
𝑁𝑢𝑚𝑏𝑒𝑟	𝑜𝑓	𝑝𝑎𝑟𝑡𝑖𝑐𝑙𝑒𝑠	 × 	100
𝐿𝑒𝑛𝑔𝑡ℎ	𝑜𝑓	𝑎𝑛𝑎𝑙𝑦𝑠𝑒𝑑	𝑎𝑥𝑜𝑛	[µ𝑚] 

15. Repeat steps 1 to 14 for all imaged neurons of a single experiment (one culture of 

hippocampal neurons from one Ccp1flox/floxCcp6flox/flox mouse). Pool data from all 

neurons of a single experiment (separately for control and hyperglutamylated neurons) 

(Figs. 1, 3). 

16. Use Prism or equivalent software to plot scatter dot plots for obtained parameters (run 

speed, run length and run duration) of all the runs and compare the medians of the 

respective distributions between control vs. hyperglutamylated neurons for 

anterograde and retrograde movements (Figs. 2, 4b-e). Exclude displacements of less 
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than 0.9 µm (average size of a mitochondrion, corresponding to 5 pixels in our 

system). See Note 15.  

17. To measure the overall motility of the particles, determine the time all imaged 

particles in one axon spend in movement within the imaging period using the 

following equation:  

𝑂𝑣𝑒𝑟𝑎𝑙𝑙	𝑚𝑜𝑡𝑖𝑙𝑖𝑡𝑦	[%] =
𝑆𝑢𝑚	𝑜𝑓	𝑎𝑙𝑙	𝑟𝑢𝑛	𝑑𝑢𝑟𝑎𝑡𝑖𝑜𝑛𝑠	𝑖𝑛	𝑡ℎ𝑒	𝑘𝑦𝑚𝑜𝑔𝑟𝑎𝑝ℎ	[𝑠] 	× 	100

𝑇𝑜𝑡𝑎𝑙	𝑛𝑢𝑚𝑏𝑒𝑟	𝑜𝑓	𝑝𝑎𝑟𝑡𝑖𝑐𝑙𝑒𝑠	 × 	𝐼𝑚𝑎𝑔𝑖𝑛𝑔	𝑡𝑖𝑚𝑒	[𝑠]  

18. Repeat the experiments (starting with cell cultures from independent mice) and 

analyses at least five times (Fig. 1). 

19. Finally, calculate the ‘average run length’ and ‘average run speed’ by calculating the 

mean of the medians (obtained in step 15) of all experiments (Figs. 1, 4b-e). Calculate 

the p-values using an unpaired t-test, or another appropriate statistical method, to 

determine to which extend the differences between control and knockout conditions 

are statistically significant. 

20. Calculate the ‘average overall motility’ and ‘average vesicle density’ from all the 

experiments by calculating the mean of the respective values (obtained in step 17) 

from all the experiments (Figs. 1, 4f-i). Calculate the p-values using an unpaired t-test, 

or another appropriate statistical method, to determine to which extend the differences 

between control and knockout conditions are statistically significant. 
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4. Notes 

1. It is crucial to control the atmosphere of the imaging chamber as it might affect the 

axonal transport. If CO2-testing equipment is not available, observe the colour of the 

cell culture medium. At sufficient CO2 levels, it should be between orange and red 

colour, whereas too low CO2 levels lead to a rather pink colour. 

2. This step of washing the neurons can be skipped if they are not transduced with 

lentivirus. 

3. Using higher concentrations or incubating for longer times with the dye can be 

deleterious to mitochondria. Thus, perform test experiments to determine a suitable 

concentration of dye at which a good signal is observed without affecting the 

dynamics of mitochondria. 

4. We prefer to use the 60´ over the 100´ objective, because it allows to image a larger 

field without compromising on the resolution. As live-imaging produces a huge 

amount of data, we set the binning at 2´2 to reduce the size of the images. However, if 

the camera resolution is not sufficient, we recommend to use 1´1 binning. 

5. It is important that neurons are seeded at low density to avoid that axons from 

different neurons grow on each other, which is what they like to do. See chapter (cite 

our other method paper) for details about neuron culture and seeding for transport 

experiments. As a general rule, avoid imaging neurons with ambiguous morphology 

(Fig. 2). 

6. The focus plane of bright-field and fluorescence are often different, therefore always 

check that the vesicles/mitochondria are in focus before acquiring. 

7. The signal from the vesicles reduces during acquisition, especially when imaging at 

higher frame rates. Thus, when adjusting the laser settings ensure that it is strong 

enough to allows detecting the cargoes throughout the imaging time. If needed, use a 

spare dish of neurons to adjust laser settings before starting the actual measurements. 

8. The rate of acquisition depends primarily on the transport cargo. For mitochondria, 

lysosomes and endosomes that undergo fast axonal transport, it is suggested to image 

at least 3 frames per second. For such high-speed imaging, we recommend to use the 

‘stream mode’ or equivalent settings in which the captured images are temporarily 

stored in the Random-access memory (RAM) of the computer. Only after the entire 

imaging is completed (1 min in our case), the images will be saved on the local hard 
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disk. This avoids any delays in the acquisition, thus allowing to capture each frame 

with high precision in timing. 

9. Alternatively, image stack file can be opened by using ‘File > Import > Image 

Sequence’ menu in ImageJ. 

10. The values are specific for each microscope, dependent on the objective and the 

camera installed. Ask your microscope facility manager or calculate the pixel value by 

using the following formula: 

𝐼𝑚𝑎𝑔𝑒	𝑝𝑖𝑥𝑒𝑙	𝑠𝑖𝑧𝑒 =
𝐶𝑎𝑚𝑒𝑟𝑎	𝑝𝑖𝑥𝑒𝑙	𝑠𝑖𝑧𝑒	 × 	𝐵𝑖𝑛𝑛𝑖𝑛𝑔

𝑂𝑏𝑗𝑒𝑐𝑡𝑖𝑣𝑒	𝑚𝑎𝑔𝑖𝑛𝑖𝑓𝑖𝑐𝑎𝑡𝑖𝑜𝑛	 × lens	magnification	 × C	mount 

11. Start tracing the axon ~15 µm distal from the cell body to avoid the axon initial 

segment, where transport is atypical [31,32]. 

12. For our imaging settings, choosing ‘width’ as 15 pixels was sufficient to cover the 

diameter of the axon. This might need to be adapted based on the resolution of the 

camera installed. 

13. If necessary, saved tracings can be loaded on to the kymograph later. This is very 

useful to modify the tracings later on. 

14. For counting the particles, we drew a horizontal line in about the middle of the 

kymograph (~30 s) and counted all particle crossing (Fig. 3g). 

15. Data can be visualized in different ways. For instance, the distribution of individual 

events (run length or run duration) in defined ranges can be represented in histogram 

plots. These plots are very useful, especially when you expect changes to occur in a 

particular speed category. This information might not be immediately visible in the 

dot plots with medians: It is possible that run length/time change only in a specific 

parameter category between control and treated neurons. 
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Fig. 1. Schematic representation of the successive steps of a single transport experiment. 

Primary Ccp1flox/floxCcp6flox/flox neurons were transduced with either GFP or GFP-2A-cre 

lentivirus on DIV0 (0 days in vitro), and analysed at DIV4. Mitochondria (stained by the 

Mitotracker® dye) movements were recorded for 1 min and their transport parameters were 

analysed using the KymoToolBox plugin. Run speed, run time, run length and overall motility 

were extracted and compared between control (GFP) and increased polyglutamylation (GFP-

2A-cre) conditions. At least five experiments are necessary to calculate the average values of 

transport parameters obtained from individual experiments. 

 

Fig. 2. Examples of neuron morphologies and their suitability for analysis. Only neurons 

with a distinct single axon (longest neurite emerging from the cell body) should be selected 

for analysis (green arrows). Neurons with ambiguous morphologies such as two axons (red #) 

or overlapping axons (red *) should not be considered for analyses. 

 

Fig. 3. Flowchart of the analysis paradigm to investigate the impact of differential 

polyglutamylation on axonal transport. (a) Hyperstack created from individual frames of 

the movie. (b) The maximum intensity projection of the mitochondria movements throughout 

the imaging period. (c) Hand-drawn line identifying the longest neurite (the axon) in which 

mitochondria transport will be analysed. (d) Kymograph and kymostack of imaged 

mitochondria created by the KymoToolBox plugin. (e) Hand-drawn trajectories of 

mitochondria runs in the kymographs. (f) Colour-coded trajectories identified from (e) (blue: 

immotile, green: anterograde, red: retrograde). 0.10 µm/sec threshold is applied for defining 

immotile particles. File with values of transport parameters of all identified trajectories (table 

format – can be saved as Excel file). For further analysis, the “Summary” lines highlighted in 

grey should be discarded, as they refer to trajectories containing several runs. Lines 

highlighted in yellow give the parameters of single runs and should be used for further 

analyses. The red box highlights the parameters used for further analysis. (g) A horizontal line 

(yellow) is drawn in the middle of the kymograph and the movement trajectories crossing this 

line were counted as the number of mitochondria in the analysed axon. 

 

Fig. 4. A representative example of data generated from a mitochondria transport 

experiments from ref. [14]. (a) All colour-coded kymographs of mitochondria movements in 

neurons with normal (GFP) and increased polyglutamylation (GFP-2A-cre) of a single 

experiment. Runs are defined as immotile (blue), anterograde (green) or retrograde (red) lines. 
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(b) A scatter dot plot of run-length distributions in different experimental conditions. The 

median values are shown below the graphs. (c) A scatter dot plot of run-speed distributions in 

different experimental conditions. The median values are shown below the graphs. (d) Bar 

graphs of overall motilities of mitochondria in different experimental conditions. It represents 

the fraction of time the organelles spent in movement throughout the imaging time. (e) Bar 

graphs of mitochondria densities in analysed neurons. (f-i) Bar graphs of mean ± SEM values 

from seven independent experiments (one experiment: a-e), showing run lengths (f), run 

speeds (g), overall motility (h) and mitochondria densities (i). The fold changes between 

control and hyperglutamylation conditions are shown below the graphs. Statistical 

significance was tested using unpaired t test. Green: anterograde movement, red: retrograde 

movement. 
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