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7.1 
Overview 

7.1.1 
Aim 

In this chapter you will learn to track cell movements within the monolayer 
epithelium of a Drosophila embryo. The segmentation of the cells is performed 
by an ImageJ macro on microscope time lapses (movies) of the embryo pre­ 
sented in the maximum intensity projection (step 1). Another macro can option­ 
ally be used to discard weak cell-cell junctions that are likely to be segmentation 
errors (step 2). The tracking is then performed in Matlab from this binary stack 
(step 3). Finally, you will learn how to visualize the results of the cell tracking 
(step 4): the cell area evolution and the cell tracks. 

7.1.2 

Introduction 

Quantitative information on the relative movement of cells and derived propert­ 
ies such as the evolution of cell areas and orientation are crucial to understand 
the organization of tissue and the fate of different cell subpopulations (Figure 7 .1, 
left). The cell-based approach usually offers much information on the processes 
during tissue remodeling in comparison to estimating the velocity field per­ 
formed by particle image velocimetry (PIV) (1,2] alone. 
In this chapter, the cell tracking is performed in the apical plane of the tissue, 

so that the tissue is modeled as a polygon tiling. This is not just a mere simplifi­ 
cation, but motivated by the fact that the strongest cell-cell junctions and most 
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Figure 7.1 Left: ln the apical plane of the tissue, the cell membrane appears as a polygon tiling. 
The red arrows point to the ventral (left) and dorsal (right) subregions. Right: Vertex model of 
cell shapes. (Figure taken from Ref. [3].) 

of the cell internal shaping forces are believed to be exerted in the apical part of 
the tissue. For image analyses, the position of the cell vertices is an invaluable · 
input to mechanical models, for example, the vertex model [3]. These models 
represent the epithelium as a 2D mechanical system with cells modeled as con­ 
stant volume elastic polyhedrons sitting below the apical plane (Figure 7.1, 
right). 

7.1.3 
Data Sets 

Data sets show the apical tissue of the embryo, which is imaged by a spinning 
disk microscope. The cell-cell junctions are labeled by a GFP-E-cadherin con­ 
struct. Three time lapses of data are provided that show the maximum intensity 
projection of different tissue morphologies and dynamics. In this chapter we will 
work only on the first time lapse, the other movies can be used in the 
assignments. 

7.2 
Step 1: Cell Segmentation 

The cell membrane appears brighter than the cytoplasm and, being the natural 
cell barrier, is highly suitable for cell segmentation. We will segment the cells in 
each time frame and generate a segmentation mask (binary image) for each 



frame. The final result is a binary stack (one image per frame). Here, we focus on 
a workflow based on the watershed algorithm, another possible solution is pro­ 
vided in the appendix. 

7.2.1 
Workflow 

Get Image Files 

Open the time lapse "TissueMoviel.tif' in Image]. 

Preprocessing 

The purpose of the preprocessing is to smooth out the images to facilitate the 
segmentation. Filter the whole image stack with a Gaussian filter of radius 1.5 
pixels: Process> Filters> Gaussian Blur ... 

Regional Minima Detection 

The cells are segmented by finding internal starting points (ideally a single 
point close to the cell center) together with the region covered by the cell utiliz­ 
ing the watershed algorithm. The watershed can be conceptualized by coding 
pixel intensities as height: The cells then appear as basins separated by higher 
watershed lines. The starting points are intensity regional minima: a region sur­ 
rounded by brighter pixels. 

To apply the watershed, call Process > Find Maxima ... with the option 
"Light Background" ticked (find minima instead of maxima). Choose a good 
value for "Noise Tolerance" (minimum relative height of surrounding bright bar­ 
rier) to get rid of spurious minima and obtain exactly one regional minimum in 
most cells. For this, tick the "Preview" option to tune the noise tolerance. 

Once you find a working value, choose the option "Segmented Particles" as 
output type: This will apply the watershed algorithm from the detected regional 
minima. This ImageJ command cannot process a whole stack at once, we will 
have to write a macro to generate the complete segmentation stack slice-by-slice. 

Exercise 7.1: Writing a Macro to Segment the Cells in the Complete Stack 

Record the sequence of operations that you manually performed in the previous 
section. Modify the code generated by the macro recorder in order to automati­ 
cally process all the slices of the time lapse. The result should be a binary stack 
showing the segmented cells. 

Hint 1: You should start by creating an 8-bit empty stack with the same dimen­ 
sions as the original stack. Each slice of the original should then be processed by 
the previous sequence of operations. 

Hint 2: You can select a slice of the active stack with the macro function set­ 
SliceO. A for-loop can be implemented to wander all the slices. The macro func­ 
tion nSlices returns the number of slices of the active stack. 



Hint 3: To transfer the resulting segmentation mask to the empty image stack, 
you can use copy/paste option. At each iteration, ensure to process the correct 
slice of the original stack and copy it to the corresponding slice of the empty 
stack. The output stack should look as shown in Figure 7.2. 

Use the macro you just wrote to process the first movie (a possible solution is 
provided in "Step1SampleCodeLoop.ijm"}. To check the results of the segmenta­ 
tion, you can use Image > Color > Merge Channels to overlay the original stack 
(in gray) and the cell boundaries (e.g., in green) as shown in Figure 7.3. 

Warning: To merge two images, they should have the same bit depth. If neces­ 
sary, convert the original image to 8 bit. 

As you can observe, it is quite likely that you do not get a perfect segmenta­ 
tion; some "false" cell junctions are sometimes created when several regional 
minima are detected in the same cell (inhomogeneous intensity inside the cell). 
This is often referred to as "oversegmentation" and can be mitigated by a proper 
preprocessing (filtering, background subtraction, etc.). ln the next exercise we will 
implement a simple manual correction. Step 2 implements an algorithm to auto­ 
matically discard weak junctions by measuring their mean intensity. 

Note: Undersegmentation is the opposite phenomenon, it takes place when a 
, single minimum is detected inside two neighbor cells (e.g., breach or weak cell 
junction). This is usually trickier to correct for; however, if cells can be assumed 
convex, then splitting lines can be drawn between concavities, for instance, by 
applying Process > Binary > Watershed. 

Figure 7.2 Output of the macro. 



Figure 7.3 Channel merging of original stack {grayscale) and segmentation {green). Some 
"false" cell junctions have been created, due to the presence of several regional minima in the 
same cell. 

Exercise 7.2: Understanding an Existing Macro 

The lmageJ macro "Step 1 CellSegment.ijm" performs all the steps previously 
described and also enables the manual correction of the segmentation mask. Try 
it out and read the code! 

The last section of the macro implements the manual correction. Try to under­ 
stand how this user interaction is written and how the cell merging is imple­ 
mented. Refer to the macro language documentation if you do not understand 
some macro functions. 

Error detection and manual inspection/correction are fundamental steps of any 
automatic analysis. Perform a thorough manual correction of the first frame of the 
movie and save the binary stack to file as it will be used in steps 2 and 3. 

Note: lmageJ segmentation masks by default are LUT inverted images so that 
the objects appear as black over a white background. When writing a macro, it is 
always a good idea to force this default behavior at initialization from Process > 
Binary> Options .... The options should appear as shown in Figure 7.4. 

7.2.2 

Summary of Tools Used 

• selectimage (ID): Activates the image with the specified ID (a negative 
number). If ID is greater than zero, it activates the IDth image listed in the 
Window menu. The ID can also be an image title (a string). 



Iterations (1-1 00): r 
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Figure 7 .4 IJ default binary options. 

• Gaussian Blur [Process> Filters > Gaussian Blur]: Smoothes out an 
image by performing convolution with a 2D Gaussian kernel of user-defined 
sigma. This helps reducing noise and disparities in the image, but smears out 
object edges and details. 

• Find Maxima [Process> Find Maxima]: The command Find Maxima iden­ 
tifies regional maxima: A regional maximum is the highest intensity pixel that 
is surrounded by a closed valley of lower intensity pixels. The noise tolerance 
defines the minimal intensity difference between the regional maximum and 
the highest intensity of its surrounding valley. 

• Copy/Paste [Edit> Copy], [Edit> Paste]: The default behavior is to copy 
all the intensity values of the pixels inside a ROI to another (active) image. The 
command Edit> Paste control allows you to change the way the image is 
copied (e.g., the background can be transparently superimposed). 

• Merge Channels [Image> Color> Merge Channels ... ]: Merging different 
channels allows you to simultaneously visualize them in the same hyperstack. 
It is possible to keep the original LUT of each channel when merging them. 

The following are the useful macro functions: 

• nSlices: Returns the number of slices/frames in the active stack. 
• setSlice(): Change the position of active stack slice slider. 

7.3 
Step 2: Removal of Weak Segments (Optional) 

We observed that oversegmentation can occur when several regional minima are 
detected in a nonhomogeneous cell. This situation can be revised since the 



intensity along a "false" cell junction is likely to be weaker than for a "valid" cell 
junction. We are now going to measure the mean intensity along each cell junc­ 
tion in the original image and remove all cell junctions with mean intensity 
below an empirical value. 

7.3.1 
Workßow 

The first task consists in detecting the cell junctions. To do so, we will first use 
the ImageJ command Plugins > Skeleton > Skeletonize (2D/3D) to 
enforce that the cell junctions are represented by a single pixel wide line. 
Note: Ensure to invert the segmentation mask before skeletonization since 

now the objects of interest are not the cells but the cell junctions! Also note that 
skeletonize (2D/3D) interprets a stack as a 3D image: You should again process 
slice-by-slice (for loop). 
Next call Plugins >Skeleton> Analyze Skeleton (2D/3D) on each skele­ 

ton image to code cell junctions and vertices {Figure 7.5} with a different inten­ 
sity. The cell junctions are now easy to segment from the output of Analyze 
Skeleton (2D/3D): They are connected particles with a gray value equal to 127. 
In the last step of the macro, the detected cell junctions will be wandered 

(loop) for each image slice and classified as "valid" or "weak" based on their 
mean intensity in the original image. 

Figure 7.5 Overlay of the original image and the analyzed skeleton. The cell junctions appear 
in orange {gray level 127), the cell vertices in purple {gray level 70), and the end points in blue 
{gray level 30, invisible in this image). 



, Exercise 7 .3: Modifying an Existing Macro 

For this exercise, we provide a fully functional macro: 
"Step2Weak.JunctionRemoval.ijm": The original movie and the segmentation 

mask generated in step 1 both must be opened and respectively named "Tissue­ 
Movie 1.tif' and ªParticlesStack.tif' before launching the macro. 

All the operations are by default performed in batch mode (no apparent win­ 
dows) so that the intermediary steps are not shown. To better understand the 
sequence of operations, perform the following tasks: 

• Comment the lines that are enabling and disabling batch mode: 
setBatchMode(true) and setBatchMode("exit and displayj 

• The segmented cell junctions are first added to the ROI manager before their 
intensity is measured. Add a pause (waitForUser) in the loop over the junctions, 
just after the ROI selection. 

• Change the value of the variable Junctionîhr and observe the effect (you can, 
for instance, use very low and very high values), try to optimize this value. 

To compare the results before and after correction, you can again use Image> 
Color > Merge Channels to create a hyperstack with three channels: original 
image and masks before and after correction (Figure 7.6). 

Save the corrected binary mask to file. 

c:113 z:201101; 364x329 pixels; 8-bit (inverting LUT); 35MB 

Figure 7.6 An example slice after cell segmentation correction. Removed junctions appear in 
green and kept junctions in yellow (red + green). 



Exercise 7.4: Making the Macro More Generic 

lt is not very convenient to have the image names and weak segment threshold 
hard-coded in the macro. Display a dialog box at the beginning of the macro 
with three UI elements: two drop-down menus (one for the original movie and 
another for the binary mask} and one numerical field ijunction threshold}. Drop­ 
down menu can be added with the command Dialog.addChoice and numerical 
field with the command Dialog.addNumber. 

To fill the names of all opened images in the drop-down menus, you will have 
to first write a small loop over all the opened images to retrieve their titles and 
store them to an array of strings that will be passed as argument to Dialog. 
addChoice. 

Hint Even if this is usually not advised, it is possible to select an image by pass­ 
ing positive numerical values to the function selectlmage, these indexes run from 
O to nlmages-1 and correspond to the order of creation/opening of the images. 

A solution to this exercise is the macro: 
HStep2WeakJunctionRemoval_dialog.ijm." 

Exercise 7.5: Advanced -Automated Threshold Selection 

Try to automate the selection of the threshold used to discard the weak cell junc­ 
tions (the solution is not provided). 

Hint: The average intensities of the "valid" junctions can be assumed quite uni­ 
form. So a good strategy is to select the threshold as a fraction of the overall 
median of junction intensities (as long as "valid" junctions are in majority). 

7.32 
Summary of Tools Used 

• addtvumbertlabel.default): Adds a numeric field to the dialog, using the speci­ 
fied label and default value. 

• add.Choicetlabel.item): Adds a pop-up menu to the dialog, where items is a 
string array containing the menu items. 

• Skeletonize - Plugins >Skeleton> Skeletonize (2D/3D): It extracts the 
medial axis of each connected particle of a binary mask, this medial axis is also 
known as skeleton (points lying at exactly the same distance from two edges of 
a connected particle in the segmentation mask). Skeletonization is a morpho­ 
logical operation based on iterative erosions (see section on Morphology in 
Module 1). The command also provides an extensive report of the skeleton 
branch statistics and can optionally prune the shortest branches. 

• AnalyzeSkeleton - Plugins >Skeleton> AnalyzeSkeleton (2D/3D): This 
command introduced in Ref. [4] is part of the Fiji distribution. From a skeleton 
(graph-like binary image), it identifies the vertices (crossing of junctions) based 



on the number of neighbors of each pixel. The junctions are coded with gray 
level 127, the vertices with gray level 70, and the end points with gray level 30. 

• waitForUser: The command waitForUser("Message") interrupts the macro 
until the user presses the "OK'' button. Interaction with ImageJ such as calls 
to internal commands or image selection/ edition is possible. This behavior is 
different from the result as you invoke showMessage("message"); in this case, 
no interaction with ImageJ is allowed: ImageJ is "frozen" until the user presses 
"OK" (pressing "Cancel" interrupts the macro). 

7.4 
Step 3: Cell Tracking 

In this section, we are going to track the cells in Matlab. The input of the script 
is the binary stack from step 1 (or step 2) and the output is a label mask with 
each cell filled by a unique gray level throughout the whole stack. 

7.4.1 

Introduction to Tracking 

Most particle trackers such as ImageJ Particle Tracker 2D/3D and TrackMate 
are built for spot-like particles: The particle linking is performed over a list of 
detected spots. The linking can be straightforward, for example, linking a spot to 
the closest spot in the next frame, or more advanced as described in Refs [5,6]. 
These trackers are not adapted to nonspot-like (or ellipsoid) objects such as 

the cells of a tissue. A possible solution is to create a binary stack made of 
detected object centroids from a segmentation mask and to process this stack 
with the tracker. This is left as an exercise in the assignments. 
Another strategy is to make use of the overlap between the particles in two 

consecutive frames. This will be illustrated in the following. 

Exercise 7 .6: Analyzing Connected Particles with Matlab 

First we review a simple Matlab script importing a binary image stack, analyzing 

I·.. 3D connected particles, and exporting the resulting label mask stack to file. 
Open the Matlab script ustep3ConnectedParticles3D.m." Before launching the 

script, set the variable BaseFolder to the folder where you saved the stack "Dum­ 
myStack.tif." The script exports the label mask stack to a file 'Labeledüummy­ 
Stack.tif' to the same folder. After launching the script, open the original stack I ::~~~• exported stack in lmageJ and go through the code to understand how it 

Hint: The function bwconncomp allows analyzing connected particles in a n­ 
dimensional image (here a 3D image). See Figure 7.7 for an illustration in two 
dimension. 
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Figure 7.7 Illustration of 2D connected particles in a 2D mask; in 3D the same principle holds 
but each voxel has 26 neighbors instead of 8. 

Exercise 7.7: Tracking Cells with Matlab 

The tñck we will use is to interpret the binary stack we generated in step 1 as a 
3D stack with time being the third dimension: The cells-overlapping from frame 
to frame are now connected in three dimension (see Figure 7.8} ! 

ln the remainder of the text, the word particle label refers to the label of a 2D 
connected particle (cell) in a given time frame (can be different for the same cell 
in two different frames). The word object label refers to the unique label of the 
cell along time (considered as a 3D object). 

Exercise 7.7.1: Understanding the Matlab Script 

Open the Matlab script "Step3TissueCelITrackv1 0_simple_incomplete.m." For 
now, do not launch the script but read the code and the functional block dia­ 
gram provided in Figure 7.9. Try to associate each block with a section of the 
program. 

Notes: 
The loop that runs the code for each object is not included yet, do not try to 

find the associated code. Also, an operation to run the code for each frame is 
missing at this point (next exercise}. 

Image stack importation and exportation are very similar to the previous 
example. 

The particles touching the edges are discarded to avoid tracking incomplete 
cells. 

The separation between the cells has to be thick enough to avoid any merging 
of neighboring cells (in 3D}, the cell junctions are enlarged by binary dilation 
(disk element of radius BoundDilate}. 

To close the top and bottom of the 3D particles, an empty image is added at 
the beginning and at the end of the movie: The binary stack passed to bwconn­ 
comp holds two slices more than the original stack. 



Figure 7.8 The cell overlap in time is apparent from orthogonal views when the movie is 
viewed as a 3D stack (Image> Stacks> Orthogonal Views). 

The 3D object label mask (Objlbl) is created by writing the labels slice-by-slice 
(second loop). lt can also be created by the Matlab function labelmatrix as in the 
previous script. This is just to illustrate an alternative method. 

The cell junctions are eroded back to their initial width at the end. 

Exercise 7.7.2: Finding the Missing Operation 

Before launching the script, set Basefolder to the folder where the input file 
(binary mask) is located. The variable fname holds the name of segmentation 
mask saved in step 1 (or step 2). After launching the script, inspect the exported 
results Tracking-objl-1 O.tif in lmageJ. You will notice that the script is not work­ 

, ing since an operation is missing: Identify it and add it to the code. 
Hint: The missing operation can be performed by a single line of code. A solu­ 

• tion to the exercise is given in 



For each frame 

Read image from frame kf --> A 
Dilate cell junctions 

Invert image 
Discard particles touching edges 

Find 2D connected particles 
-->CC 

Draw centroids of connected 
particles 

--> PartCentroids 

Find 3D connected particles 
--> Objlbl 

For each object 

Count number of centroids in each 
frame 

Discard object from Objlbl 

Figure 7.9 Worktlow of the cell tracker (Algorithm 1 - TissueCellTrackv10). 

"Step3TissueCel1Trackv1 O_simple.m." 
To better visualize the exported stack in lmageJ, you can apply the LUT Ran­ 

dom.lut provided in the code folder. To do this, you first have to copy the LUT 
into the subfolder Juts of lmageJ installation folder and call Help > Refresh 
Menus. 

Note: The script also exports a stack holding the centroids of the 2D particles 
found in each frame. lt will be used during the assignments to track the cell 
centroids. 

This simple algorithm suffers from a severe limitation: Dividing or transiently 
merging cells (undetected cell junctions) are assigned the same label. ln the next 
section, we will implement a procedure to detect these situations and automati­ 

li cally discard the problematic cells. 



Exercise 7.7.3: Discarding Erroneous Objects 

You can now open the script ªStep3TissueCel1Trackv1 0.m." This algorithm is 
described by the block diagram in Figure 7.9. ln the second part, a loop is per­ 
formed over each 3D object and the number of 2D particles (centroids) inside 
the object is computed for each frame. If more than one centroid is found in at 
least one frame, then the object is discarded in all frames (label set to O). Of 

J 
course, this is not ideal, but following the same idea one could detect events of 

•. : merge and division and split the 30 object in frames where merge and division 
occur (set label to O) before recomputing the 30 connected objects. 

7.5 
Step 4: Feature Extraction 

In this section, we will plot the evolution of the cell area against time (i.e., the 
recorded frame) as well as track the position of the centroids of sorne of the 
cells. The input of all the scripts of this section is the label mask that we have 
computed (and saved to file) in step 3. 

Exercise 7.8: Plotting Cell Area Evolution 

Open the Matlab script "Step4PlotCellAreaExercise.m" and check that the base 
folder and file name are correctly set in the script preamble. 

The script only displays the area evolution for a subset of cells of the label 
mask. The variable displaylbl is a vector taking the indices of the user-defined 
cells from which the information is to be extracted (ensure that these indices do 
not exceed the maximum value of the label mask!). The script is incomplete: ln 
the loop over all the time frames, you should add the missing code to compute 
the areas of the cells of interest and store them in the variable Area(cellindex, 
frame). 

Hint: Inside the loop over the time frames, you should write a loop over all the 
labels stored in displaylbl, compute the areas of each cell, and store this area to 
the matrix Area(for the correct cell, for the correct frame index). A way to com­ 
pute the area of a cell at a given frame is to count how many pixels are set to the 
label of this cell in that particular frame. 

I The solution to the exercise is provided in ªStep4PlotCellArea.m." 

Exercise 7.9: Plotting Cell Centroid Tracks 

4 Try now to retrieve the centroids of the cells in each frame with regionprops il (Obj,'Centroid'). Store theses positions to two arrays: X(frame} and Y(frame} 
~ and plot the tracks to a 20 map. The solution to the exercise can be found in 
.l'i "Step4PlotCellAreaTrack.m." 



7.5.1 

Complete Track Plotting 

A program plotting all the cell tracks (with start and end points labeled) and 
overlaying them to the first frame of the label mask is provided in "Step4Cell­ 
TrackPlotter.m." The workflow of the program is described below and a possible 
output is illustrated in Figure 7.10 (without the label mask overlay). 

First we define a minimal track length MinimalLengthoITrajectory to discard 
short tracks that are often erroneous. 
In order to get the total number of objects, we find the last label index nbmax­ 

cell (pixel with maximum value in the object label stack). 
Then we create a vector of Matlab structures called cells. The vector is 

indexed by the object label. Each element of this structure array gathers two 
features of a given cell: the list of time frames where it is present and the list of 
its centroid positions in these frames. The structure is filled by the results 
returned by the Matlab function regionprops. Other features can be easily added 
to the structure array. 

Finally, we plot the cell centroids for each time frame by sequential calls to 
plot. Only the tracks of length above MinimalLengthoITrajectory are plotted and 
the graphics are directed to the same canvas by calling hold on. The tracks are 
additionally decorated to mark their start and end points. 
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Figure 7.10 Example of cell tracks plotted for movie 1. Each blue line represents a cell 
trajectory, the first point of the trajectory is a red circle and the last point a green circle. 



7.6 
Assignments 

If you intend to use the other two movies, you will notice that they suffer from a 
strong lateral drift; it is hence important to first register them, for instance, by 
applying Plugins > Registration > StackReg before the segmentation. This 
will allow a more efficient tracking in step 3. 

• Tracking of cell centroids: In step 3 we generated a stack holding the cell cen­ 
troids extracted from the segmentation mask. We can use this centroids stack 
as input to a spot-like particle tracking algorithm. In light microscopy, an infi­ 
nitely small particle would never appear as a single isolated point but rather as 
a Gaussian-like shape (the point spread function of the microscope). This can 
easily be simulated by performing a 2D Gaussian blurring (radius around 1 
pixel) of the centroid stack. 
After this filtering process, the centroid stack with Plugins > Mosaic > 

Particle Tracker or Plugins >Tracking> TrackMate. You should set 
the particle size to the minimum setting and prefer DoG (Difference of Gaus­ 
sian) to LoG (Laplacian of Gaussian) detector in TrackMate. 

• PIV analysis: To complement the analysis, we will now apply PN to the same 
movies. The PN is a procedure to estimate the velocity field of a time lapse at 
discrete positions and for each time frame. The PN will be computed by 
ImageJ with Analyze> Optic flow> PIV Analysis. This function generates 
two images: The image U codes the X component of the velocity field, while 
the image V codes its Y component. We will export these two images to file, 
import them in Matlab, and visualize the velocity field (vector field) with the 
function quiver. To test this workflow, follow these steps: 
1) Create a two-frame movie by duplicating an image with Image > Dupli­ 

cate ... and slightly shift the second frame. Save this stack as "twoframes.tif." 
2) Call Image} Analyze > Optic Flow> PIV analysis on the stack. The 

displacements are represented as a color-coded image and they are also 
provided as two images (one for each speed component). 

3) Spatially average the U and V components by applying Process > Smooth. 
4) Save the filtered images U and V as text files with File > Save As > Text. 

When saving an image as text file, the values of the pixels are sequentially 
written as text (strings) separated by spaces. The values are written line-by­ 
line with a return carriage at the end of each line. 

5) Launch the following Matlab script ("XAssignVisPivMatlab.m"): 

1 % Folder where "U.txt" and "V.txt" are saved 
2 Basefolder = ' ... \'; 

3 
4 % Load the text files and copy the values to the 

matrices u and v 
5 u= load([Basefolder,'U.txt']); 



6 v = load([Basefolder,'V.txt')); 
7 
8 % Load first frame of the time-lapse 
9 imagetissue imread([Basefolder,'twoframes.tif'] ,1); 

10 
11 % Display the vector field overlaid on the first 

frame of the time-lapse 
12 imshow(imagetissue, [)); 
13 hold on; 
14 quiver(v,u); 

code/XAssign VisPivMatlab.m 

The ImageJ macro "XAssignPIVCompute.ijm" performs the previous work­ 
flow. The script "XAssign VisuOutputPN.m" is an advanced version of the pre­ 
vious Matlab script to visualize the vector field in Matlab. The output should 
look as in Figure 7.11. 

• Overlap-based cell tracking: The tracking algorithm based on 3D connectivity 
is simple, but the results are not fully satisfactory as dividing and merging cells 
are discarded from the label mask. The algorithm proposed in this section will 
correctly track most of the cells up to a division/ merging. 
Here the cell linking is performed iteratively and by processing pairs of con­ 

secutive time frames. The tracking starts from the first frame and proceeds 
through the time lapse, it is extremely important to check that the segmenta­ 
tion mask is valid in the first frame. 
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Figure 7.11 Example result of the PIV analysis. The first frame is green and the second frame is 
red. The displacements between first and second frames are indicated by green arrows. 



For each frame 

Read image for frame kf -> A 
Invert image 

Discard particles touching edges 

J, 

Analyze connected particles in A -> Partlbl PartLbl -> Objlbl Count number of particles -> Npart >-First frame?➔
Compute particle areas -> AreaPart Npart -> Nobj 

I For each particle in the current frame r- • 
i Compute area of all overlapping 

i 
objects 

from previous frame -> PartObjArea 

' ---± 
Erase Objlbl 

i 

I For each particle in the current frame .. ; ' 
! 

Assign the label of the object 
with largest overlap -> Objlbl ¡ 

I 
i 

1 I 
I 

Detect particles not assigned 
to any object label 

-> NewPart I 
-> Nnewpart 

I For each appearing particle • 
Fill NewPart in Objlbl with index Nobj 

Nobj +1 -> Nobj 

------- I .. ' ¡ 
Export Objlbl I 

! 

-- ---·- ~- ------------ - . ·-- - --------- I 
Figure 7.12 Workflow of the cell tracker (Algorithm 2 - TissueCelITrackv20). 

Open the script "XAssignTissueCellTrackv20.m" and launch it after setting 
BaseFolder. A block diagram of the script is provided in Figure 7.12. 
The object label mask (ObjLbl) is now built recursively: In the first frame, 

the 2D connected particles (PartLbl) are copied to the object label (ObjLbl) of 
the first frame. Particles here means connected objects in one frame, i.e candidate 
cells to be assigned to an object (i.e tracked cell). The 2D particles are then 
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Figure 7.13 Steps involved to build the object overlap between the particles at timet and 
label mask Objlbl at time t from the object the objects at time t-1. The numbers represent 
label mask at time t-1 and the particle label the labels of the objects. 
mask at time t. OvlMap{t) represents the 

analyzed in the next frame t (PartLbl t) and their overlap with the object(s) in 
frame t-1 (ObjLbl t-1) are computed Each particle is then assigned the most 
likely object label from the previous frame (maximum overlap), this label is 
written to the object label mask of the current frame (ObjLbl t). The pro­ 
cess is then iterated until the last frame of the movie. 
The label masks are illustrated for a simple case in Figure 7.13. It can be 

clearly understood that if there is no overlap between the same cell in two 
consecutive frames (large drift or fast movement), the linking will fail. Two 
other problems arise if the largest overlap does not take place between the 
correct pair of cells or if two cells get transiently merged. 
Try to modify the script "XAssignTissueCellTrackv20.m" so that a particle is 

assigned the label of the object with largest overlap only if this overlap is larger 
than a user-defined area threshold (e.g., 70% of the area of the particle). The 
solution to the exercise is found in "XAssignTissueCellTrackv20_solution.m." 



Solutions to the Exercises 

Exercise 7 .1 

1 li Initialization 
2 NoiseTol = 5; 
3 run{"Options ... ", "iterations=l count=l edm=Overwrite"); 
4 
5 li Filter input image 
6 run {"Duplicate ... ", "title=Filtered duplicate"); 
7 run{"Gaussian Blur ... 11, "sigma=l.5 stack"); 
8 
9 li Create empty stack of same size as active image 

10 newimage{"ParticlesStack", 118-bit Black", getWidth{), 
getHeight{), nSlices); 

11 run { 11 Invert LUT 11 ) ; 
12 
13 I I Main loop 
14 for{i=l;i<=nSlices;i++) 
15 
16 selectimage{"Filtered"); 
17 setSlice{i); 
18 run( "Find Maxima ... 11, "noise="+d2s (NoiseTol, 2) +" 

output=[Segmented Particles] light"); 
19 rename{"Particles"); 
20 run ( 'lCopy"); 
21 selectimage{"ParticlesStack"); 
22 setSlice{i); 
23 run {"Paste"); 
24 selectlmage {"Particles"); 
25 close {); 
26 
27 run {"Select None") ; 

"code/SteplSampleCodeLoop.ijm" 

Exerci~e 7.2.3: The Code Should Be Opened from the Provided Material 
("Step 1 CellSegment.ijm" and "Step2WeakJuctionRemoval.ijm'1 

Exercise 7 .4 

1 //Parameters 
2 if(nimages<2)exit("At least two images should be opned!"); 
3 ImageNames = newArray(nimages); 
4 for (i=0; i < nimages; i++) 
5 { 
6 selectimage(i+l); 
7 ImageNames[i] = getTitle(); 



8 
9 Dialog.create("Select Images"}; 

10 Dialog.addChoice("Original Movie", ImageNames, ImageNames(0]}; 
11 Dialog. addChoice ( "Binary Mask", ImageNames, ImageNames [l]) ; 
12 Dialog.addNumber("Threshold", 50); 
13 Dialog.show{); 
14 OriginalMovie = Dialog.getChoice(); 
15 SegmentedCells = Dialog.getChoice(}; 
16 JunctionThr = Dialog.getNumber(); 
17 
18 // Initialization 
19 run("Options ... ", "iterations=l count=l edm=Overwrite 

do=Nothing"); 
20 run("Set Measurements ... ", " mean redirect="+OriginalMovie+" 

decimal=2"); 
21 setBatchMode(true); 
22 newimage("CorrectedMask", "8-bit Black", getWidth(}, 

getHeight(), nSlices); 
23 
24 // Main loop over th.e slices 
25 for(s=l;s<=nSlices;s++) 
26 
27 
28 
29 // Set current slice in all stacks 
30 selectimage("CorrectedMask"); 
31 setSlice(s); 
32 selectimage(OriginalMovie}; 
33 setSlice(s); 
34 selectimage(SegmentedCells); 
35 setSlice(s); 
36 
37 // Skeletonize and identify junctions I vertices 
38 run {"Duplicate ... ", "title=Copy") ; 
39 run("Invert", "slice"); 
40 CopyID = getimageID(); 
41 run("Skeletonize (2D/3D) 11); 

42 
43 run("Analyze Skeleton (2D/3D)", "prune=none prune"); 
44 AnalyzedSkeletonID = getimageID(); 
45 
46 // Add all junctions to ROI manager and measure mean 

intensity in original stack 
47 setThreshold(l00, 255); 
48 // Threshold junctions: vertices value: 70, junctions value: 127 
49 run ( "Analyze Particles ... 11, "size=0-Infinity circularity=0. 00- 

1. 00 show=Nothing display clear add"); 
50 roiManager("Show None"); 



51 
52 li Select non null pixels in the skeleton--> mask 
53 selectimage(AnalyzedSkeletonID}; 
54 setThreshold{l, 255); 
55 run{"Convert to Mask", "method=Default background=Dark 

black"); 
56 run {"Invert LUT") ; 
57 resetThreshold(); 
58 
59 li Erase the weak junctions 
60 N = roiManager{"count"); 
61 for (i=0;i<N;i++) 
62 
63 if(getResult("Mean",i)<JunctionThr) 
64 { 
65 roiManager("Select", i); 
66 run("Set ... 11, "value=0 slice"); 
67 
68 
69 
70 li Copy to CorrectedMask 
71 run ("Select All"} ; 
72 run ("Copy"} ; 
73 selectimage("CorrectedMask"}; 
74 run ("Paste"); 
75 
76 li Cleanup 
77 selectimage(AnalyzedSkeletonID); 
78 run{"Close"); 
79 selectimage(CopyID); 
80 run ("Close"); 
81 
82 
83 I I Exit 
84 selectimage("CorrectedMask"); 
85 run{"Invert", "stack"); 
86 run ("Invert LUT") ; 
87 run ("Select None") ; 
88 setBatchMode("exit & display"); 
89 run{"Set Measurements ... ", " mean redirect=None decimal=2"); 

"code/Step2WeakJunctionRemoval_dialog.ijm" 

Exercise 7.6 

1 BaseFolder = ' ... \'; 
2 fname = strcat{BaseFolder,'DummyStack.tif'); 
3 expfname = strcat(BaseFolder,'LabeledDummyStack.tif'); 



4 
5 % Gather ParticleStack image info 
6 info= imfinfo(fname); 
7 num_images = numel(info); 
8 Height= info(l) .Height; 
9 Width= info{l) .Width; 

10 
11 % Initialize buffer image 
12 DummyStack = zeros(Height,Width,num_images); 
13 
14 % Read images (loop over frames) 
15 for kf = l:num_images 
16 DummyStack(:, :,kf) = imread(fname, kf, 'Info', info); 
17 end 
18 
19 % Find connected particles (3D) 
20 CC= bwconncomp(DummyStack}; 
21 
22 % Generate label mask 
23 L = labelmatrix{CC); 
24 
25 % Erase output file (if exists) 
26 if exist(expfname, 'file') 
27 delete(expfname); 
28 end 
29 
30 for kf = l:num_images 
31 imwrite {uintl6 (L (:,: ,kf)), expfname, 'WriteMode', 'append', 

'Compression' ,'none'); 
32 end 

"code/Step3ConnecteclParticles3D.m" 

Exercise 7 .7 

1 %% Initialization 
2 clear all; 
3 close all; 
4 BaseFolder = ' ... \'; 
5 fname = strcat(BaseFolder,'ParticlesStack.tif'); % 

Segmentation mask 
6 expfnameobj = strcat(BaseFolder,'Tracking-objl-10.tif'); % 

Object labels 
7 expfnamepartcentroids = strcat{BaseFolder,'Tracking­ 

Centroids-v-10.tif'); % Centroid stack 
8 
9 %% Parameters 

10 startframe = l; 



11 BoundDilate = 5; 
12 
13 %% Gather ParticleStack image info 
14 info = imfinfo (fname); 
15 num_images = numel(info); 
16 Height= info(l) .Height; 
17 Width= info(l) .Width; 
18 
19 %% Create image buffers with same size of the original image 

(+ 2slices) 
20 ImageCopy = zeros(Height,Wid,th,num_images+2); 
21 ObjLbl = zeros(Height,Width,num_images+2); 
22 PartCentroids = uint8(zeros(Height,Width,num_images+2)); 
23 
24 %% Loop over image frames (2D processing) 
25 for kf = 1:num_images 
26 disp(kf); 
27 
28 % Import mask for this frame 
29 A imread(fname, kf, 'Info', info); 
30 
31 % Dilate cell junctions 
32 A imdilate(A, strel('disk' ,BoundDilate)); 
33 
34 % Process mask and analyze connected particles (2D) 
35 A 255-A; % Mask coming from ImageJ (inverted LUT) 
36 A= imclearborder(A); % Remove objects touching the image 

borders 
37 
38 % Store current frame to ObjLbl 
39 ImageCopy(:, :,kf+l) = A; 
40 
41 % Find connected particles in current frame and compute 

their centroids 
42 CC= bwconncomp(A); 
43 centroids= regionprops(CC,'centroid'); 
44 
45 % Draw centroids of connected particles 
46 for 1 = l:length(centroids) 
47 centroidl = centroids(l) .Centroid; 
48 PartCentroids(round(centroidl(2)),round(centroidl(l)), 

kf+l) = l; 
49 end 
50 
51 end 
52 
53 %% Analyze connected particles (3D) to identify objects and 

fill label mask 



54 objList = bwconncomp(ImageCopy); 

55 Nobj = objList.NumObjects; 
56 for label= 1:Nobj 
57 ObjLbl(objList.PixelidxList{label}) 
58 end 
59 
60 %% Images post-processing and exportation 
61 
62 % Erase output file (if exists) 
63 if exist(expfnameobj, 'file') 
64 delete(expfnameobj); 
65 end 
66 
67 % Erode the cell junctions and export the object label mask 
68 for frame=2:num_images+l 
69 ObjLbl2D = imdilate(ObjLbl(:, :,frame),strel('disk', 

label; 

BoundDilate)); 
70 imwrite(uint16(ObjLbl2D), expfnameobj, 'WriteMode', 

'append', 'Compression' ,'none'); 
71 end 
72 
73 % Erase centroid stack file (if exists) 
74 if exist(expfnamepartcentroids, 'file') 
75 delete(expfnamepartcentroids); 
76 end 
77 
78 % Export the centroid stack 
79 for frame= 2:num_images+l 
80 imwrite(uint8(PartCentroids(:, :,frame)), 

expfnamepartcentroids, 'WriteMode', 'append', 
'Compression' ,'none'); 

81 end 

"code/Step3TissueCellTrackvl0_simple.m" 

Exercise 7 .8 

1 
2 
3 
4 
5 
6 

clear all; 
close all; 
start frame 
displayLbl 
BaseFolder 

1; 
[54 57] ; 
I • ••\I j 

fname = strcat(BaseFolder,'Tracking-objl-10.tif'); % 
Exported stack (object) 

7 
8 %%%% Read the object label mask (same label 

cell over time)%%%%%%% 
9 info = imfinfo (fname}; 

same 



10 num_imagcs = numel(info); 
11 endframe = num_images; 
12 
13 % get information from last frame 
14 A= imread(fname, endframe, 'Info', info); 
15 
16 % Find highest label: total number of cells 
17 nbmaxcell = max(max(A)); 
18 
19 % Initialize arrays 
20 Area= nan(nbmaxcell,endframe); 
21 
22 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% 
23 
24 for kf = startframe:endframe 
25 A= imread(fname, kf, 'Info', info); 
26 for Lbl=displayLbl 
27 Obj = (A==Lbl); 
28 Area(Lbl,kf) = sum(sum(Obj)); 
29 end 
30 end 
31 plot(startframe:endframe,Area(displayLbl, :)); 

"code/Step4PlotCellArea.m" 

Exercise 7.9 

1 clear all; 
2 
3 
4 
5 
6 

close all; 
startframe 
displayLbl 

1; 
[54 57]; 

BaseFolder ' ... \'; 
fname = strcat(BaseFolder,'Tracking-objl-10.tif'); 

Exported stack (object) 
% 

7 
8 %%%% Read the object label mask (same label 

cell over time)%%%%%%% 
9 info= imfinfo(fname); 

10 num_images = numel(info); 
11 endframe = num_images; 
12 
13 % get information from last frame 
14 A= imread(fname, endframe, 'Info', info); 
15 
16 % Find highest label: total number of cells 
17 nbmaxcell = max (max (A)); 
18 
19 % Initialize arrays 

same 



20 Area= nan(nbmaxcell,endframe); 
21 X nan(nbmaxcell,endframe); 
22 Y= nan{nbmaxcell,endframe); 
23 

25 
26 for kf = startframe:endframe 
27 A= imread{fname, kf, 'Info', info); 
28 for Lbl=displayLbl 
29 Obj= (A==Lbl); 
30 Area{Lbl,kf) = sum{sum{Obj)}; 
31 stats= regionprops(Obj,'Centroid'); 
32 stats= cat(l,stats.Centroid); 
33 if(~isempty(stats)) 
34 X(Lbl,kf) stats(l,1); 
35 Y(Lbl,kf) = stats{l,2); 
36 end 
37 end 
38 end 
39 plot(startframe:endframe,Area(displayLbl, :)); 
40 figure; 
41 plot(X{displayLbl, :) .' ,Y{displayLbl, :) .'); 

"code/Step4PlotCellAreaTrack.m" 

7.7 
Appendix 

In the alternative workflow "XAssignMacroSegmentationalternative.ijm," the 
cells are segmented by video inverting the fluorescence signal so that they appear 
as bright on a dark background. A step of background subtraction facilitates 
thresholding and then a binary watershed is applied with an intent to split the 
merged cells. 
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