
Working with ELAN 

 

This tutorial accompanies the chapter “11. Annotating Multimodal Data of Singing and 

Speaking” by Coralie Vincent in Frank A. Russo, Beatriz Ilari and Annabel J. Cohen (Eds), The 

Routledge Companion to Interdisciplinary Studies in Singing, Vol. 1: Development (2020), 

pp. 149–166. Routledge. DOI: 10.4324/9781315163734 

The tutorial elaborates specific steps complementing the processes described in the chapter. 

Page references to relevant sections in the chapter are added in parentheses. 

 

  



1. Building a Coding Scheme (p. 159) 

For example, to define soprano notes, follow steps 1) to 4). 

1) Create a Parent Tier and name it (e.g., “Soprano” for the vocals of a soprano singer): 

Tier > Add New Tier…  

In the “Add Tier” window, type in Tier Name: the name of your choice, e.g. Soprano (check 

that Parent Tier: says none). Click Add then Close (not clicking Add will not create the tier). 

 

  



2) Next, define the Controlled Vocabulary for the soprano’s notes. Go to 

Edit > Edit Controlled Vocabularies…  

In the “Edit Controlled Vocabulary” window, type in CV Name: the name of your choice, e.g. 

notes-soprano. Click Add on the right. 

 

 

  



Now, type in Entry value: the lower limit of your choice for the vocal range, e.g. C4 and click 

Add below. Then type in Entry value: C4♯ / D5♭ and click Add, and so on until A5 is reached (or 

any other upper limit relevant for the considered vocal range). 

 

To finalise this step click Close for this window. 

  



3) Create the Type for soprano notes. Go to 

Type > Add New Tier Type… 

In the “Add Type” window, type in Type Name: the name of your choice, e.g. the CV Name 

given in the previous step, notes-soprano. Select Stereotype: Included In (as notes can be 

separated by pauses, they are non-contiguous; hence this choice). For “Use Controlled 

Vocabulary”, choose the CV Name given in the previous step, e.g. “notes-soprano”. Click Add 

then Close to exit the “Add Type” window (not clicking Add will not create the type). 

 

  



4) Create the referring tier for soprano notes. Go to 

Tier > Add New Tier…  

In the “Add Tier” window, type in e.g. “Notes S” (“S” is short for “Soprano”) in the Tier Name: 

field. For Parent Tier:, choose “Soprano”. Check that Tier Type: is the type given in the previous 

step, e.g. “notes-soprano”. Click Add then Close to exit the "Add Tier” window (not clicking 

Add will not create the tier). 

 

... Repeat steps 1) to 4) for the other categories and sub-categories in order to create the entire 

coding scheme. 

 

The coding scheme can be checked in View > Tier Dependencies…. To display the Timeline 

Viewer hierarchically, right-click the left part of the window and select Sort Tiers > Sort by 

Hierarchy. 

 



2. Preparing Multimodal Data to Annotate with ELAN (pp. 159‒161) 

2.1.Music-Score Video (p. 159) 

Here is an example of creating a movie from a MIDI file of the score. This requires three 

software programmes: MuseScore, a text editor, and FFmpeg. 

 

1) Converting a MIDI score to images with MuseScore 

In MuseScore’s “Start Centre” window, click Open a score… to open the MIDI file. 

 

Change the page layout to define the ratio of the final video file (ideally 4:3 or 16:9): 

 Format > Page Settings… 

In the “Page Settings” window define the parameters according to the desired output e.g.: 

Page Size: Custom 

Unit: * inch 

Width: 8.00in 



Height: 6.00in or 4.50in (respectively for a 4:3 or 16:9 video file) 

The radio button right below should automatically switch to:  Landscape 

Uncheck: 

 Two sided 

Odd Page Margins should all be set to the same positive value (for example 0.39in). 

To save changes and exit the “Page Settings” window, click: OK 

 

  



To adjust the background parameter for the images (white or transparent), go to 

 Edit > Preferences… 

In the Export tab, uncheck:  Transparent background 

To save changes and exit the “MuseScore Preferences” window, click: OK 

 

  



Finally, in MuseScore main window, go to  

File > Export… 

In the “Export” window, select Type: PNG Bitmap Graphic (*.png) and Save. 

 

  



2) Creating a text file of the timecode of the images in a text editor 

Based on the main video or audio recording to be annotated, manually determine the time when 

each page image is to be displayed (automatic audio-to-score alignment will hopefully be 

available in the near future; see Gong, Cuvillier, Obin, & Cont, 2015). To set the timecodes, 

indicate the location of each image and the timecode for the intended display duration in 

seconds and milliseconds, as follows: 

file 'path\to\image01.png' 

duration n.nnn to display the first frame during n.nnn s (format is [s.ms]) 

file 'path\to\image02.png' 

duration p.ppp 

Repeat for all images. The code must end with the path and a repeat of the name of the last 

image:1 

file 'path\to\imageNB.png' 

For example: 

 

  

                                                 
1 Due to a bug in FFmpeg, the last duration should be divided by two (see screenshot above for an example). 



3) Open a command window (terminal on Mac and Linux) to run FFmpeg. 

Execute the following command to create a movie containing the images: 

> ffmpeg -f concat -safe 0 -i "path\to\timecode_file.txt" -vf "scale=640:480,format=yuv420p" 

"path\to\movie.mp4" (scale=640:480 for 4:3; scale=640:360 for 16:9). 

 

  



2.2.Motion Capture Video (p. 160) 

Mokka can be used to export data as an image series and create a video sequence of images 

with FFmpeg. This video will allow to preview motion capture data in ELAN. In this specific 

case, as all images have the same duration (the reciprocal of the motion capture sampling rate), 

a video can also be created through Avidemux. 

1) Launch Mokka 

File > Open… 

Select the .trc motion capture (MoCap) file in the “Open” window. 

Then go to 

File > Export > Image Series… 

 

2) Open a command window (terminal on Mac and Linux) to run FFmpeg. 

Execute the following command to create a movie containing the images: 

> ffmpeg –framerate 120 -i "path\to\images\FFFpIsp1_a_%03d.png" -vf format=yuv420p 

"path\to\movie.mp4" (with MoCap recorded at 120 Hz and images sequentially named 

FFFpIsp1_a_001.png, FFFpIsp1_a_002.png, FFFpIsp1_a_003.png, etc.). 

 



2.3.Audio (p. 160) 

Launch Avidemux 

File > Open 

Select the video file in the “Select Video File...” window. 

Next, on the left side of the main window, choose Audio Output: PCM and in the main menu: 

Audio > Save audio. Type the audio filename (including .wav). 

 

 

2.4.Time Series (p. 160, p. 161) 

Line graphs can be displayed from .csv files or .txt files containing a pair of time-values (values 

can be in any range) separated by a comma on every line. Each line has to be written in the 

following format 



Time (floating point value [s.ms]),Value (floating point value [q.qqq]) 

Example: 

0,137.771316681753 

0.00833333,137.671734122537 

 

Importing time series  

After the time series has been created, it is possible to import and view it (Edit > Linked Files...). 

Previously imported media files are listed in the “Linked Files” window, under the Linked 

Media Files tab. In order to link the time series, select the Linked Secondary Files tab. Click 

Add…, navigate to the relevant tier file (.csv, .tsv, .txt, .IntensityTier or .PitchTier file). Click 

Select in the “Select” window. In the “Linked Files” window, click Apply (otherwise, the file 

will not be linked). A .xml file containing information about the Linked Secondary Files is 

automatically created and stored at the same level as the .eaf file (using the same name followed 

by “_tsconf.xml”, for TimeSeries CONFiguration). The Timeseries Viewer will then open (see 

Figure 11.1 (3) in the chapter, p. 151). 

If this is a direct import without configuration (for example a .IntensityTier or a .PitchTier file), 

the graph is shown right away. If this is an import with configuration (for example a .csv files 

or a .txt file with time-value pairs separated with a comma), no graph is shown. Right-click in 

the Timeseries Viewer, then click Configure Tracks…. This opens a window showing the 

parameters for the graph, including the Derivative of the data: none (0), first (1: velocity), 

second (2: acceleration), and third (3: jerk). When linking two or more time series files, they 

can be superimposed in the same TrackPanel, or displayed in different TrackPanels by right-

clicking in the Timeseries Viewer. 

 



3. Importing Pre-existing Annotations or Making New ones (p. 161) 

3.1.Importing annotations (p. 161) 

3.1.1. An Optional preliminary step (p. 161) 

To the annotation layer previously exported from Sonic Visualiser, add a column containing 

the end time (which equals the next start time), as Sonic Visualiser only exports tab-separated 

time-value pairs (start time and value). For example, a text file with chord estimation: 

0.000000000    N 

8.618666666    F 

10.325333333    C#maj7 

11.477333333    Bbm 

should be changed to: 

0,8.618666666,N 

8.618666666,10.325333333,F 

10.325333333,11.477333333,C#maj7 

11.477333333,12.757333333,Bbm 

This can be easily done in a text editor or in a spreadsheet program like LibreOffice Calc, and 

saved as a .csv file. 

 

3.1.2. First step: transforming a .csv file into a .eaf file (p. 161) 

File > Import > CSV / Tab-delimited Text File… 

In the “Open” window, navigate to the .csv file and click Open. 

Next, in the Import Options and Select columns and specify their data type, select Begin Time 

for column 1, End Time for column 2, and Annotation for column 3, then click OK. A new 

ELAN window will open, containing the annotations. Save the file in the appropriate folder. It 

is now possible to close the file and go back to the first ELAN file to which these annotations 



should be added. 

 

3.1.3. Second step: merging the resulting .eaf file with the original annotation file 

(p. 161) 

File > Merge Transcriptions… 

In Second source, find and select the .eaf annotation file that has just been created from the .csv 

file. In Destination, create and save a new .eaf file. In the “Merge Transcriptions” window, 

click Next and then Finish. Finally, click Yes to open the new transcription in ELAN and close 

the .eaf file which was used before the merging (it is possible to switch between open ELAN 

files with the Window menu). 

 

3.2.Getting coordinates / positions (p. 161) 

Select the tier into which this annotation should be added: double-click its name in the left part 

of the Timeline Viewer. Pause the video at the appropriate time. Click in the Media Player to 

copy the location of the mouse pointer into the clipboard. In the Control buttons (see Figure 

11.1 (6) in the chapter, p. 151), check “Selection Mode” and click “Go to next frame” for frame-

by-frame tracking. Create the annotation: Annotation > New Annotation Here. Now, paste the 

content of the clipboard into the annotation: press the keys “ctrl” (“command” on a Mac) and 

“v” at the same time. The results should look something like “377,97 [640,360]”; the first two 

numbers give the x and y positions of the point of interest in the video, and the numbers in 

square brackets indicate the picture size. 

 

  



4. Query of Annotations, Generation of Statistics and Saving Results (p. 161) 

4.1.Searching in an Annotation File (p. 161) 

Once the file is annotated, assessing consecutiveness (for example in pianissimo and mezzo 

piano in the Soprano I voice nuances) can be done this way: 

Search > Find (and Replace)... 

In the “Search Dialog” window, select An annotation on tier: Nuance S1 that matches: mezzo 

piano and click Add constraint. Check that WITH structural constraint is selected. Right below, 

select An annotation on tier: Nuance S1 matches: pianissimo in distance of: -1 to: 1 Nuance S1 

annotations. Then click Search at the bottom of the “Search Dialog” window. While this 

window is open, it is possible to navigate through the search history by clicking < or > at the 

top of it. A constraint can also be deleted by clicking Delete right below this constraint. 

Be aware that regular expressions can be included in the searches by checking the regular 

expression box on the right of the same window. More information about regular expressions 

can be found in ELAN’s help appendix. 

Still in the “Search Dialog” window, the matched substring can be replaced in the results of a 

search: 

Edit > Replace 

This operation can be done on a set of files. In the ELAN main window, go to Search > Find 

and Replace in Multiple Files…. and click Define search domain. 

Similarly, a search can be done on multiple annotation files: 

Search > Search Multiple eaf… 

 

  



Software 

Used software (version when it matters): 

 Avidemux 2.7.3 

 ELAN version 5.9 

 FFmpeg 

 LibreOffice 

 Mokka 0.6.2 

 MuseScore 3.4.2 

 

Dedication and acknowledgment 

The author would like to dedicate this tutorial to the memory of Dominique Boutet, an ELAN 

enthusiast who had been training colleagues and students to use this software for countless years. 
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