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Introduction

Summary

The aim of the workshop is to show how OpenJUMP can be used to help building and
managing a Spatial Data Infrastructure (SDI).The figure 1 illustrate the logical system of our
SDI and figure 2 the technical application.

Here,  you  will  learn  how  to  create  a  PostGIS  database  and  how  to  add  data  to
OpenJUMP. Visualization,  styling  and  geoprocessing  with  OpenJUMP will  be  illustrated  with
simple examples.
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Figure 1

Figure 2



This document is organize in two steps which allow a progressive learning of OpenJUMP.

1. Using OpenJUMP
This part guides you throught some basic OpenJUMP skills. You'll learn how to :

– load and display data,
– working with alphanumeric data,
– thematic maps,
– exporting views
– querying and geoprocessing

2. Using OpenJUMP in SDI context

This part is the most important step in the workshop. We will  demonstrate how it's
possible to create and manage a simple SDI with OpenJUMP. Two sections are developed. 

First in the section “OpenJUMP and Postgis” we use PostgreSQL and PostGIS spatial
functions to increase spatial analysis. You can create advanced spatial processing and querying
single or multiple data source with SQL command line. You'll learn how to :

– searching for strings, values,
– building expressions with more than one criteria,
– searching and creating new data by their location.

Secondly,  the  section  “  OpenJUMP  advancing  to  a  OGC  client”  is  intended  as  an
introduction  to  web services.  Connection  with  deegree  WFS protocol  will  be  shown and a
simple client browser will be used. 

Materials

We need to have : 

– OpenJUMP foss4g edition available at http://www.projet-sigle.org,
– PostgreSQL database and postGIS extension available at 

http://www.postgresql.org/,
– Deegree tools (web services and web browser) available at http://www.deegree.org,
– OpenOffice 2.0 available at http://www.openoffice.org/,
– Inkscape available at http://www.inkscape.org/.

And spatial data, available at http://www.projet-sigle.org
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Data

Zip file Data Geometry Description

frenchprovinces frenchprovinces polygon Regional country

bzhdepartements bzhdepartements polygon Sub french country after province

municipalities22 municipalities22 polygon Municipalities for Côtes-d'Armor departement

watershed

watershed polygon Watershed name's Sterenn

subwaterhed polygon Sub watershed in Sterenn

wsmunicipalities polygon Municipalities crossing Sterenn watershed

roads_waternetwork
roads line Roads network in Sterenn watershed

waternetwork line Ditches and rivers in Sterenn watershed

landcover_hedgerow
landcover2000 polygon Land cover classification in 2000

hedgerow line Hedges network in Sterenn watershed

topographicmap
F018_024.TIF

F018_025.TIF

aerialphoto1998
photo2_ecw.ecw

photo3_ecw.ecw

Raster 
image 

Topographic map (tif + world file)

Topographic map (tif + world file)

Aerial photography (ecw)

pop22-5499 Population by municipality 1954 to 1999 in Côtes-d'Armor 
(Bretagne)

dataRGA Farming evolution by municipality
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Using OpenJUMP

 1 Loading and displaying data

 1.1 Loading and organizing data

When OpenJump starts,  you will  see a main window named “project”  (figure  3).  A
“project” is not only a window which allows data visualisation and organisation but it’s a file
too, which must contain all the work you do with OpenJump (.jmp extension).

First,  you  will  load  some  vectorial  layers.  So  from  the  File  Menu,  choose  “Select
datasets”. You have to select : 

– frenchprovinces.shp,
– bzhdepartements.shp,
– municipalities22.shp,
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Figure 3

Figure 4



Loaded layers are listed in a table of contents, to the left of the visualisation window
(figure 4). We will call it Layer View.

There are many ways to move in the Layer View and to zoom in to or out of the areas 
shown in it. So, we will ask you to use navigation tools (directly from the toolbox, from the 
View Menu or by a right-click in the table of contents).

zoom in/out,

zoom to full extent

zoom previous/next

zoom to fence

zoom to selected items

zoom to scale Turn on View > Zoom to scale

zoom to layer or layers Right-click on a selected layer 

 1.2 Modifing layer properties

To modify layer styles, you can use the Styles dialog (figure 5).

The  Rendering Tab  (figure  6)  enables  you  to  change  general  properties  (colour,
transparency, line width and pattern, vertices visibility).

The Scale Tab (figure 7) allows you to customize the scale display. So you can define
that a layer can be shown only between a smallest and a largest scale.  To know the current
scale, you must select “show scale” from the View Menu.

The  Labels Tab (figure 8) enables you to define labelling options (font : type, colour
and height, placement). You have to know especially what attributes you want to label on the
layer.
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Figure 5



Exercise (figure 9)

Symbolise frenchprovinces
Uncheck fill 
Set gray lines width=7

Symbolise bzhdepartements
Uncheck fill
Set black lines width=2
Label using field name_dept

Symbolise municipalities22
Set presets style yellow
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Figure 6

Figure 7

Figure 8

Figure 9



Then, from the File Menu, you will load some raster files :
– photo2_ecw.ecw
– photo3_ecw.ecw
– F018_024.TIF
– F018_025.TIF

Raster files should be listed in a new category (named Fond) in the table of contents. In
the Layer View, to have a better visibility, you can create, rename and move the categories in

the table of contents and order as you want (figures 10,
11 and 12).
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Figure 10

Figure 11

Figure 12



Exercise : customize the raster scales

For photo2_ecw.ecw and photo3_ecw.ecw, smallest scale = 12 000
For F018_024.TIF and F018_025.TIF, smallest scale = 15 000

To help you, you can display the scale in numeric value. Turn on View>Show scale

 2 Working with alphanumeric data

 2.1 Viewing attributes

In  a  layer, each  feature  has  alphanumeric  attributes.  If  you  want  to  inspect  the
attributes of layer, you can use the toolbox or choose “View/Edit attributes” after a click-right
in the table of contents (figure 13).

You will see a new window named “Attributes” (figure 14).
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Figure 13

Figure 14



Another way to reach specific attributes is available by selecting one or many features
directly in the Layer View with the Info tool

 2.2 Importing and joining alphanumeric data

There, we want to join demographic data with the layer named “municipalities22”.

Open pop22-5499.ods with OpenOffice. Turn on File> Save as. Choose text CSV. Set
values as figure 15. 

Right-click on “municipalities22” in the table of contents, and choose “join data” (figure
16).

In the dialog that appears, All Files select file named “pop22-5499.csv”. 
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Figure 15

Figure 16



Click the first dropdown arrow and click the field name in the layer that the join will be
based on (Figure 18).

Click the second dropdown arrow and click the field in the table to base the join on
(Figure 18).

Click OK

The attributes of
the  table  are
appended  to  the
layer's  attribute
table (figure 19).
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Figure 17

Figure 18

Figure 19



To keep the result, you must save the layer.

 2.3 Modifying layer schema

With OpenJUMP you can easily add or remove fields from a table if the layer is editable. 
Right-click on the layer municipalities22 and check “Editable”. 

Right-click on the layer municipalities22 and select “View/Edit Schema”. A new window
appears. All fields are listed and described. By this way, we can know the data type of each
field (string, numeric, boolean, geometry ...)

In the Edit Schema, click on the lasted row to add a new field “area”. Click the Data
Type dropdown arrow and click the field type. Click Apply Changes (figure 21).
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Figure 20

Figure 21



Then, it’s possible to populate a field.

In this part, we will ask you to calculate areas of “municipalities22” features. 

Turn on Statistic >Calculate areas and lengths. Select what kind of operation you want
to do and specify the right field (figure 22).

The results are expressed as m². You have to convert their as km². The Pirol  attribute
tools lets you perform simple calculations on all records.

Turn on Pirol Tools>Attribute tools>Editeur de formules.

Set name AREA_KM2

Click type DOUBLE 

Set  expression  like
figure 23

Click OK
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Figure 22

Figure 23



This tool will create automatically the new field (area_km2) in the attribute table.

Exercise (figure 25)

Calculate population densities in 1999 and 1954.

PMUN99 and PMUM 54= population, numbers are in thousands.

Population density (habitants/square kilometres)
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Figure 24

Figure 25



 3 Thematic maps

First, create a new project. In this project, copy the three vectorial layers (copy-paste).

Turn on View Manager > Mosaic. 

Turn on View, select  “active synchronisation”  a new button “Synchronize”  must be
appear in the menu tool bar. Click on. Zoom in to a view. Views are synchronized (figure 26).

Don't forget, you should have the same vectorial layers in both projects.

In each project, you will colour-theme municipalities layer by one attribute (figure 28).

– project 1 : density 1954
– project 2 : density 1999

Open the “change styles” window.

The Colour theming tab enables you to choose the classification method, the number of
ranges and the attribute  to colour theme. Then it’s  possible  to modify  the colour scheme
(figure 27).
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Figure 26



 4 Exporting views

For each projects add a scale bar. Turn on View>Scale Bar.

You can export a layout and its legend to svg or png files. So you can complete, modify
their, in another programs (Inkscape for example)
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Figure 27

Figure 28



From File Menu, select “save image in a svg format” or “save image as” (figure 29).

Right-click on the layer in the table of contents and choose “save legend as png”.

 5 Querying 
data

5.1 Simple attributes queries

Load datasets (figure 30) :

– landcover2000.shp,
– rivers.shp,
– roads.shp,
– hedgerow.shp,
– watershed.shp,
– subwatershed.shp,
– wsmunicipalities.shp.
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Figure 29



Select  forest  parcels  (in  2000)  with  areas  exceeding  one  hectare  (10  000  square
meters).

Turn  on  Selection>Queries>simple  query. it  will  open  a  new  dialog  named  “Query
Builder” (figure 31).

The Query Builder enables to save your queries and to choose what kind of result you
want (features selection, table display or new layer)
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Figure 30

Figure 31



Select moisture value and replace it by “wetlands”. 

Go to Query Builder. Select moisture value in landcover2000.

Make layer editable.

Turn on Layer>Replace value (figures 33 et 34).

5.2 Spatial queries
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Figure 32

Figure 34

Figure 33



What are the parcels within 100 meters of roads ?

Go to Query Builder. Set (figure 35) 

Layer = landcover2000

Attribute = (GEOMETRY)

Operator = is within (100.00)

Value = road
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Figure 35

Figure 36



Exercises 

Exercise1 

What are the wetland parcels within 100 meters of municipal roads ?

Exercise2 

What are the hedges which touch grassland parcels ? Note their total length and display the
result in a new layer.
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Using OpenJUMP in a SDI context

 1 OpenJUMP and Postgis

 1.1 Create a database and load postgis extension

Start pgAdmin tool to manage database.

Go to file Add server

Set :

Adress : localhost

Description : Foss4g workshop

Servive : « null »

Mainteance DB : template1

User name : admin

Password : foss4g

You should obtain this (figure 38).

Figure 37

Figure 38



Create a database (figure 39)

The  PostGIS  extension  requires  the  PL/PgSQL  procedural  language  for  some  of  its
functions.

If plpgsql doesn't exist. Right-click on language and set parameters like figure 40.
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Figure 39

Figure 40



Now, let's go to load postgis functions.

Open SQL query builder 

1. Load lwpostgis.sql and execute it
(figure 41)

2. Load spatial_ref_sys.sql

Now we are ready to import and to work with spatial data and features in PostgreSQL.

 1.2 Using Postgis

 1.2.1 Basic exercises

 1.2.1.1 Populating database

Prepare data

Create a new project. In this project :

Open shapefiles :"waternetwork.shp" "roads.shp" "watershed.shp"

Open rasters files : “photo2_ecw.ecw” “photo3_ecw.ecw” 

For each layers

Open  layer  schema  and  change
geometry name by the_geom.

Add a gid column. Right-click on a
layer  and  select « Add  gid
column ».

Change SRID add code for french
projection  :  EPSG:27582  -
NTF(Paris)/Lambert II (étendu)
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Figure 41

Figure 43

Figure 42



Create a new project. In this project :

Open shapefiles :"waternetwork.shp" "roads.shp" "watershed.shp"

Open rasters files : “photo2_ecw.ecw” “photo3_ecw.ecw” 

Right-click on a layer  and select
« Change SRID ».

Import shaphefile in gisdb

Select the layer to be imported

Turn on File>Save dataset as

In the combobox Format  choose
Postgis Table.

Figure  44  show  parameters  and
the option to create a new table
name  watershed  in  gisdb
database

 1.2.1.2 Display postgis layer in OpenJUMP

Turn on File>Load dataset as

In the combo box Format choose 
Postgis Table.

Set :
Connexion name : foss4g
Server : localhost
Database name : gisdb
User : admin
Password :foss4g

You can save the parameters by 
using the save icon (Figure 45).

Click on the button Connection
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Figure 44

Figure 45



Figure 46 : The tables contained 
in the database are listed in a 
tree.

Select roads table and click OK.

The layer is loading in 
OpenJUMP.

Open  waternetwork,  roads  and
watershed layers.

 1.2.1.3 Editing, modifing and creating a postgis layer

Open rasters files : F018_024.TIF and F018_025.TIF. 

Modify watershed style to display topographic maps. 

Extract in another layer, the features waternetwork where the column type_axe is equal
to river value. Name this layer rivers.

Symbolize the new layer with a 4 thick blue line (Figure 47).
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Figure 46

Figure 47



Here you can show that features rivers aren't continuous. There are three breaks in the
network (see red boxes on figure 47).  The aim is  now to  complete  the river  network by
drawing new features.

Zoom to the north red box

Make rivers editable

Use the draw line tool to create a new line 

If necessary reshape the line 
by adding, 

moving 

or deleting vertices.
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Zoom in to control snapping error 
Perform vertex by using snap box.

To use it draw a rectangle across the vertex

Before snapping 

After snapping

Set the attributes of the new features

Use the Feature Info tool to display its attributes

Put the value “river” into the type_axe column 
(figure 48)

To do for each new features. 

Don't forget to upload the gid column and save 
rivers in to postgis.

 1.2.1.4 Filtering a postgis layer

To  filter  a  postgis  layer  and  display  results  in  OpenJUMP  you  can  use
ExecuteQueryDialog plugin, a small GUI to run sql syntax (Figure 49).
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Figure 48



Turn on Layer>Ajouter une requête 
Postgis”or use this button 

In the new window click on 

Set postgis parameters and press

(figure 50)

Warning there isn't any message to inform you about the connection. To test if the 
connection is activate close the window and click on 

If you show a window like figure 7, your connection is right. Otherwise, you should 
repeat it again.

This window show the public schema of the 
database gisdb. By clicking on a tree node you
can display :

- the name of the tables, 

- the name of the columns and their format.

Filtering roads layer to display road where type is equal to municipality

You must use this syntax :
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Figure 51



SELECT asewkt(<geometry column>) as the_geom, <column list> FROM <table> WHERE 
<column name>=<value>

So here (figure 52):

Press 
to execute the query

A new category is created and a 
new layer appears.

To keep it, turn on File>Save data 
set as> Postgis Table

To save the query press

Filtering roads layer by length

SELECT asewkt(the_geom) as the_geom, type, gid FROM roads WHERE length(the_geom) 
<500

Unit is metric (meters).

Exercise 

Find in landcover2000 features which are
                 - grassland and
                 - area greater than 2 hectares

The result must be display in OpenJUMP and layer must contains three columns :
gid, type and area.

Notes : 
function area is area(<geometry column>)
10 000 square meters is equal to 1 hectare

Don't forget that SRID value is 27582 and unit is metric

 1.2.2 Advanced exercises
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 1.2.2.1 Configuring iSQLViewer

With the iSQLViewer an open source client for database, you can use more complex SQL
expressions like CREATE, UPDATE... Moreover, you can use successive queries and bookmark
then.

Turn on Layer>iSQLViewer for OpenJUMP (figure 53).

Click on Yes.

Click on Create a new iSQL service. Select Local Service.

Set  parameters  as
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Figure 54

Figure 55



showing on figure 56. Click on Save/apply (figure 57).

Test the tool by using a simple query (figure 68). 
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Figure 56

Figure 57

Figure 58



 1.2.2.2 Practises 

Find parcels contains in wsmunicipality named QUEMPERVEN (figure 59)

SELECT  landcover2000.type  FROM  landcover2000,  wsmunicipalities  WHERE
contains(wsmunicipalities.the_geom,  landcover2000.the_geom)  AND
wsmunicipalities.name_mun='QUEMPERVEN'

To  load  the  query  result  in  OpenJUMP,  you  must  use  the  same  syntax  like
ExecuteQueryDialog plugin. The SQL statement would be :

SELECT  asewkt(landcover2000  .the_geom)  as  the_geom,  landcover2000.type  FROM
landcover2000,  wsmunicipalities  WHERE  contains(wsmunicipalities.the_geom,
landcover2000.the_geom) AND wsmunicipalities.name_mun='QUEMPERVEN'

Create a buffer on rivers where the 20 distance value represents a higth risk of pollution
by pesticides. (figure 60)

SELECT asewkt(the_geom, 20)as 
the_geom FROM rivers

Set new layer in red color and save it. Put
the name buffrivers
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Figure 59
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Find parcels intersects the buffer layer

SELECT asewkt(landcover2000.the_geom)
as the_geom, landcover2000.type FROM  
landcover2000, buffrivers WHERE 
intersects(buffrivers.the_geom, 
landcover2000.the_geom)

Set new layer in yelow color.

All in one 

SELECT  asewkt(landcover2000.the_geom)  as  the_geom,  landcover2000.type  FROM
landcover2000,rivers  WHERE
intersects(buffer(rivers.the_geom,20),landcover2000.the_geom)  AND  rivers.the_geom  &&
landcover2000.the_geom

To use this you will create a spatial index for each tables. The SQL statement is :

CREATE  INDEX  landcover2000_gidx  on  landcover2000 using  gist  (  the_geom
gist_geometry_ops );

VACCUM ANALYSE;

Unfortunately, there is a bug in iSQLViewer with PostGIS operators && , & < , and & >.
However, you can test it with the simple postgis plugin.

Store complex statement in a view

For example, if you want to known how hedges touched a parcel with contain cereals.
You need to use often this. 

CREATE  VIEW  hedgerow.the_geom  FROM  hedgerow,  landcover2000  WHERE
contains(landcover2000.the_geom, hedgerow.the_geom) AND landcover2000.type='cereals'
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 1.2.2.3 Watershed statistics : calculate and diffuse

The aim is to calculate environmental statistics by watersheds. This statistics will be 
published on internet in a html page and inform the decision maker about a potential pollution 
risk by pesticides. 

Calculate statistics

What is the total length of the rivers in the big watershed and add the result in a 
column named riverlength

First: add a column in watershed layer.

ALTER TABLE watershed ADD COLUMN riverslength float8;

Secondly: populate the column

UPDATE watershed SET riverslength=sum(length(rivers.the_geom)) FROM rivers;

Lastly : display result

SELECT * FROM watershed;

In iSQLViewer you can execute all statements
only once (figure 62).

To delete a column : ALTER TABLE DROP
COLUMN

W  hat is the density in meters by hectare of all hegdes contains in the big watershed. 
Add the result in a column named hedgesdens

Firstly: add three columns in watershed layer.
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ALTER TABLE watershed ADD COLUMN wsarea float8;

ALTER TABLE watershed ADD COLUMN hedgeslength float8;

ALTER TABLE watershed ADD COLUMN hedgesdens float8;

Secondly: calculate wsarea 

UPDATE watershed SET wsarea=(area(watershed.the_geom)/10000);

Thirdly: create a view

CREATE  VIEW  hegdebigws  as  SELECT
intersection(watershed.the_geom,hedgerow.the_geom)  as  the_geom  FROM  watershed,
hedgerow;

Fourthly : load result in OpenJUMP

Fifthly : set up the column  hedgeslength

UPDATE  watershed  SET  hedgeslength=(sum(length(hegdebigws.the_geom)))  FROM
hegdebigws;

Sixthly : calculate density

UPDATE watershed SET hedgesdens=hedgeslength/wsarea;

Lastly : display result and cartography it

SELECT * FROM watershed;
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Figure 63 : Hedgerow layer Figure 64 : View hegdebigws



Export watershed map and statitics in a simple html file

Firstly : Export watershed statistics in a html page.

Run this query (figure 65)

SELECT  name_ws,  riverslength
,wsarea,hedgeslength,
hedgesdens FROM watershed

Turn on File>Export>Export data 
(figure 66)

Select HTML format and set the 
parameters like picture 

Click next>next and save your page
with the name mysimplepage.html.
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Figure 65

Figure 66



Create a map with watershed, 
hedgerow and rives.

Symbolise watershed
ColorTheme based on name_ws 
attribute
Select preset style 
Set label
Watershed

Symbolise hedgerow
ColorTheme based on type attribute

For hedgeTalus
Unchek fill
Set line pattern = 7
Set green lines width=3
Change label like Hedge on talus

For talus
Unchek fill
Set green lines width=3
Change label like Talus

Symbolise rivers
ColorTheme based on type attribute
Unchek fill
Set blue lines width=3

In view zoom to watershed and add scale bar (figure 70).
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Figure 67

Figure 68

Figure 69

Figure 70



Now export each legends is the 
same folder like  
mysimplepage.html (figure 71).

Select layer, right click > Save 
legend as png.

Names :

hedgelegend.png

riverslegend.png

watershedlegend.png

Integrate map in html page

Export view in svg. Turn on File > 
Save image in SVG format
Name map.svg

Open map.svg in a text editor.
Note width and height value

Open map.svg with inkscape
Add legends and save

Open mysimplepage.html in a text 
editor. Below body add

Run mysimplepage.html in your 
web browser

<rect x="0" y="0" width="813" style="stroke:none;" 
height="621" />

<body>
<embed src="map.svg" width="813" height="621" 
type="image/svg+xml" name="emap">
<div>
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Figure 71

Figure 72



Exercise

Calculate statistics by watersheds : 

hedgerow density
road density by type
rivers length

Display  result  in  html  page  with  a  map  witch  represents  parcels  risk  watershed,
subwatersheds, roads and rivers

Notes

Merge roads by type

SELECT geomunion(the_geom),type FROM roads GROUP BY type;

Display geometry type

SELECT gid,geometrytype(the_geom) FROM rivers;

Working with SRID

Get SRID

SELECT getsrid(the_geom) FROM landcover2000 LIKE 1;

Change SRID

SELECT updategeometrysrid(rivers, the_geom, <new srid value>);

Then, use setSRID to change geometries internal SRID:

SELECT setsrid(the_geom, <new srid value>) FROM rivers;
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